VirtueMart E-Mail Pro und VirtueMart Rechnung Pro
Ergebnis 1 bis 8 von 8
  1. #1
    Neuer Benutzer
    Registriert seit
    02.10.2017
    Beiträge
    1

    Kann keine Produkte in den Warenkorb legen

    Hallo Leute,
    ich sehe vor lauter Bäumen den Wald nicht mehr. Wer kann bitte helfen?

    Ich kann leider keine Produkte mehr in den Warenkorb legen, dies funktionierte aber ich nachdem ich zuviel "rumgespielt" habe mit den Kategorie-und Produkteinstellungen, funzt das nicht mehr.

    Joomlaversion: 3.4.8
    VirtueMart 3.0.7.4
    PHP Version 5.6.31-he.0

    Hier mal ein Link zu meiner Seite.
    xxxxxxx

    Ausserdem sehe ich auf der Startseite unter den Produkten nur noch den "Details" Button und nicht mehr den kleinen Einkaufswaren.
    Geändert von StefanSTS (04.10.2017 um 10:41 Uhr)

  2. #2
    Erfahrener Benutzer
    Registriert seit
    06.05.2013
    Ort
    Lonavala
    Beiträge
    2.034
    Servus,

    Du scheinst ja alles wieder repariert zu haben. Gerade hat das in den Warenkorb legen jedenfalls funktioniert.

    Du fährst auf einer unsicheren Joomla und VirtueMart-Version, deshalb hab ich den Link einmal rausgenommen. Wir wollen hier keine Spielkinder in Versuchung führen.

    Im eigenen Interesse wäre es sinnvoll, die Versionen zeitig zu aktualisieren.

    Grüße
    Stefan

    PS: Ich sehe gerade, Du hast dort einen Full Installer installiert und der Shop scheint noch nicht fertig zu sein. Tue Dir den Gefallen und beginne mit einer frischen Joomla-VirtueMart-Installation. Du wirst sehr bald in Schwierigkeiten laufen, wenn Du einen englischen Full Installer ohne richtige Sprachkonfiguration auf deutsch umbaust.
    Geändert von StefanSTS (04.10.2017 um 10:50 Uhr) Grund: PS
    --
    Stefan Schumacher
    www.schumacher-netz.de
    VirtueMart Admin Template https://www.jooglies.com/virtuemart-...admin-template

    Im Forum gebe ich gerne öffentlich kostenlose Hilfestellung für allgemeine Probleme, wenn meine Zeit es zulässt.
    Diese Hilfe soll der Allgemeinheit zu Gute kommen und baut durch das Forum eine Wissensdatenbank für Antwortsuchende auf.
    Private Nachrichten bitte nur, wenn kommerzieller Support gewüscht wird; auch meine Zeit ist nur begrenzt.

  3. #3
    Neuer Benutzer
    Registriert seit
    18.10.2017
    Beiträge
    3

    gleiches oder ähnliches Problem bei der Virtuemart-Einrichtung

    Hallo Leute,

    ich versuche seit Stunden, den Virtuemart-Shop zum Laufen zu bringen und komme nicht weiter.
    Mit Joomla arbeite ich seit vielen Jahren, Virtuemart ist neu für mich.

    Joomla!-Version 3.7.2 Stable
    PHP-Version 7.1.6-nmm1
    VirtueMart 3.2.4

    Es lassen sich keine Produkte in den Warenkorb legen, von Anfang an nicht. Die plus/minus-Tasten beim "in den Warenkrob" Button für die Anzahl der Produkte, gehen auch nicht, aber man kann die Zahl verändern, wenn man reinklickt.

    Willkommen bei Yoga Infos

    Am Template liegt es nicht, es funktioniert auch nicht mit anderen.
    Module und Plugins habe ich aktiviert und deaktiviert, ohne Erfolg.
    Debug-Modus hilft nicht, Fehlermeldungen gibt es keine.
    Ich habe viele Beiträge dazu gelesen und nehme an, dass es mit den Einstellungen des Java-Scripes zusammen hängt. Diese habe ich in allen möglichen Variationen ausprobiert, ohne Ergebnis.
    So sehen die Einstellungen zur Zeit aus, in der Konfiguration unter Stilvorlagen:


    Kann jemand helfen?

    Gruß,
    Sangeet

  4. #4
    Erfahrener Benutzer
    Registriert seit
    06.05.2013
    Ort
    Lonavala
    Beiträge
    2.034
    Servus Sangeet,

    als erstes einmal PHP 7.0.x versuchen bitte.

    Grüße
    Stefan

    PS. Und wenn Du schon seit vielen Jahren mit Joomla arbeitest, weißt Du ja, dass alte Joomla-Versionen nicht taugen. ;-)
    --
    Stefan Schumacher
    www.schumacher-netz.de
    VirtueMart Admin Template https://www.jooglies.com/virtuemart-...admin-template

    Im Forum gebe ich gerne öffentlich kostenlose Hilfestellung für allgemeine Probleme, wenn meine Zeit es zulässt.
    Diese Hilfe soll der Allgemeinheit zu Gute kommen und baut durch das Forum eine Wissensdatenbank für Antwortsuchende auf.
    Private Nachrichten bitte nur, wenn kommerzieller Support gewüscht wird; auch meine Zeit ist nur begrenzt.

  5. #5
    Neuer Benutzer
    Registriert seit
    18.10.2017
    Beiträge
    3
    Hi Stefan,

    danke schon mal für die schnelle Rückmeldung.

    Ich habe auf PHP 7.0 umgestellt, keine Veränderung.

    (und Joomla ist jetzt auch auf 3.8.1 aktualisiert)

    Gruß,
    Sangeet

  6. #6
    Erfahrener Benutzer
    Registriert seit
    06.05.2013
    Ort
    Lonavala
    Beiträge
    2.034
    PHP würde ich trotzdem auf 7.0.x lassen.

    Schau einmal in der VM - Konfiguration, ob dort im Reiter Stilvorlagen
    Fancybox, Vm jQuery, Produkt-Skripte und Ajax for product content angeklickt ist.
    Im Reiter Kasseneinstellungen noch:
    Modales Pop-Up Fenster beim Klick auf ' In den Warenkorb' anzeigen - ja

    Dann sollte es funktionieren. Wenn nicht, scheint doch ein Modul, Plugin, Slider mit dem jQuery zu kollidieren.

    Grüße
    Stefan

    --
    Stefan Schumacher
    www.schumacher-netz.de
    VirtueMart Admin Template https://www.jooglies.com/virtuemart-...admin-template

    Im Forum gebe ich gerne öffentlich kostenlose Hilfestellung für allgemeine Probleme, wenn meine Zeit es zulässt.
    Diese Hilfe soll der Allgemeinheit zu Gute kommen und baut durch das Forum eine Wissensdatenbank für Antwortsuchende auf.
    Private Nachrichten bitte nur, wenn kommerzieller Support gewüscht wird; auch meine Zeit ist nur begrenzt.

  7. #7
    Neuer Benutzer
    Registriert seit
    18.10.2017
    Beiträge
    3
    In der VM-Konfiguration ist alles entsprechend angeklickt, das war auch schon so voreingestellt.

    Dann sollte es funktionieren. Wenn nicht, scheint doch ein Modul, Plugin, Slider mit dem jQuery zu kollidieren.
    Gibt es da Erfahrungswerte? Muss ich alle Plugins/Module einzeln deaktivieren, oder gibt es eine Abkürzung?

    Gruß,
    Sangeet

  8. #8
    Erfahrener Benutzer
    Registriert seit
    06.05.2013
    Ort
    Lonavala
    Beiträge
    2.034
    Oft wird im HEAD-Tag unnötiges jQuery mehrmals geladen, da würde ich mal nachschauen, ob die Reihenfolge richtig ist, und ob alte jQuery-Versionen geladen werden. Mootools evtl. deaktivieren, wenn das noch geladen wird. Plugin von PHPRoberto hilft da.

    Manchmal hilft es auf das reine Protostar-Template umzuschalten, weil dann einige Module nicht geladen werden.
    --
    Stefan Schumacher
    www.schumacher-netz.de
    VirtueMart Admin Template https://www.jooglies.com/virtuemart-...admin-template

    Im Forum gebe ich gerne öffentlich kostenlose Hilfestellung für allgemeine Probleme, wenn meine Zeit es zulässt.
    Diese Hilfe soll der Allgemeinheit zu Gute kommen und baut durch das Forum eine Wissensdatenbank für Antwortsuchende auf.
    Private Nachrichten bitte nur, wenn kommerzieller Support gewüscht wird; auch meine Zeit ist nur begrenzt.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •