VirtueMart E-Mail Pro und VirtueMart Rechnung Pro
Ergebnis 1 bis 7 von 7
Like Tree1Likes
  • 1 Post By StefanSTS

Thema: Allemeine Variablen plötzlich nicht mehr richtig eingstellt

  1. #1
    Neuer Benutzer Avatar von gizmo_m
    Registriert seit
    13.05.2016
    Beiträge
    8

    Allemeine Variablen plötzlich nicht mehr richtig eingstellt

    Hallo zusammen
    Ich "darf" für einen Freund seine Joomla!/VM Seite betreuen, da IT-Kenntnisse doch sehr auf "Benutzer" beschränkt sind
    Die Seite läuft seit einiger Zeit und hat bis anhin nie Probleme gemacht.

    Seit einigen Tagen haben sich aber 2 Probleme bemerkbar gemacht und ich kann beim besten Willen nicht nachvollziehen, woher diese Probleme kommen könnten.

    1. Selbsterstellte Felder - Allgemeine Variablen

    Es ist so dass er bei allen Produkten (T-Shirt's, Hoodies, Jacken etc.) Produktvarianten für versch. Farben und mittels selbsterstellter Felder die Auswahl für Grösse eingepflegt hat.
    Dazu wurde die Option in den "Allgemeinen Variablen für Produktvarianten" so gesetzt, dass "Stammprodukt als Option" und "Stammprodukt bestellbar" eingeschalten sind

    Bis vor kurzem konnte dann natürlich das Produkt angeschaut werden und falls die Farbe des Stammprodukts stimmt nur noch die Grösse geändert werden und dann ab in den Warenkorb.

    Und plötzlich beim Anschauen des Produkts ist die Option "in den Warenkorb" nicht mehr aktiv.

    Ich hab dann mal probiert auf der Übersichtsseite eine Variante auszuwählen, dann wechselt er natürlich automatisch zum Produkt mit der ausgewählten Variante und diese kann dann auch in den Warenkorb gelegt werden.
    Die Kontrolle der Optionen in den Allgemeinen Variablen hat gezeigt, dass die beiden Haken plötzlich weg waren und das interessanterweise nicht bei allen Produkten sondern nur bei einigen

    Den Grund zu nennen warum das passiert ist, kann und will ich nicht erwarten
    ABER, gibt es eine Möglichkeit, bei allen Produkten diese Optionen gleichzeitig wieder herzustellen anstatt jedes Produkt einzeln zu öffnen, richtig stellen, speichern und das nächste Produkt ändern?
    Wäre sehr hilfreich, 1. bin ich dann sicher dass alle wieder Richtig sind und 2. würde es Stunden an Arbeit ersparen (über 2000 Produkte/Produktvarianten)

    2. Anzeige der Produktvarianten

    Da er von jedem Stammprodukt (wie oben beschrieben) Varianten eingepflegt hat für jede einzelne Farbe, sollten diese auch richtig dargestellt werden beim Wählen einer Variante.

    Seit kurzem (könnte in etwa zur gleichen Zeit passiert sein wie oben beschriebenes Problem) wechselt beim Wählen einer Variante die Anzeige nicht mehr auf die richtige Farbe, obwohl in jeder Variante das Bild mit der richtigen Farbe eingepflegt ist.

    Gibt es eine Option/Einstellung die ich Überprüfen kann, ob und wie das eingestellt ist?
    Hab gesucht aber leider nix gefunden...

    Da der Shop so nicht wirklich zu gebrauchen ist, haben wir diesen für den Moment (Wartungsarbeiten ) deaktiviert sonst hagelt es Kritik und Anfragen etc.

    Bin um jede Hilfe, jeden Input dankbar
    Vielen Dank im Voraus und Gruss aus der Schweiz
    Marcel

  2. #2
    Erfahrener Benutzer
    Registriert seit
    06.05.2013
    Ort
    Lonavala
    Beiträge
    1.959
    Hallo Marcel,

    die Einstellungen für die selbsterstellten Felder kann man evtl. über die Datenbank wieder auf 1 setzen. Da würde ich in den Tabellen einmal nachsehen.

    Probleme tauchen oft auf, wenn VirtueMart aktualisiert wird, aber kein aktuelles Template verwendet wird. Die meisten Templates ändern viele Ansichten und wenn sie nicht aktualisiert werden, greifen sie evtl. nicht richtig auf geänderte oder neue Funktionen zu.

    Hilfreich ist die Angabe der Versionen aller Komponenten, um hier zu helfen. Joomla, VirtueMart, Template, mitwirkende Erweiterungen.

    Grüße
    Stefan

    PS. bitte dies einmal lesen: Wie bekomme ich schnellstens hilfreichen Antworten
    --
    Stefan Schumacher
    www.schumacher-netz.de
    VirtueMart Admin Template https://www.jooglies.com/virtuemart-...admin-template

    Im Forum gebe ich gerne öffentlich kostenlose Hilfestellung für allgemeine Probleme, wenn meine Zeit es zulässt.
    Diese Hilfe soll der Allgemeinheit zu Gute kommen und baut durch das Forum eine Wissensdatenbank für Antwortsuchende auf.
    Private Nachrichten bitte nur, wenn kommerzieller Support gewüscht wird; auch meine Zeit ist nur begrenzt.

  3. #3
    Neuer Benutzer Avatar von gizmo_m
    Registriert seit
    13.05.2016
    Beiträge
    8
    Hallo Stefan
    Vielen Dank für Deine Antwort.
    Stimmt, Versionsnummern anzugeben wäre wohl nicht sooo schlecht gewesen
    Hatte ich total vergessen nach so viel Schreiben
    Sorry for that

    Also hier der Nachtrag:
    Joomla!: 3.7.3
    VM: 3.2.2
    Template: AS Designing - AS 002045 Vers. 2.1 (Das Original-Template resp. Quickstart Package kommt mit VM vorinstalliert)
    PHP: 7.1

    Da der Shop aktuell Offline ist, bringt wohl ein Link darauf nix.
    Bei Bedarf ins Backend einzuloggen kann ich kurz einen User generieren, der Admin-Rechte hat. Dazu bitte eine PN.

    Vielen Dank für Deine Hilfe
    Gruess
    Marcel

  4. #4
    Erfahrener Benutzer
    Registriert seit
    06.05.2013
    Ort
    Lonavala
    Beiträge
    1.959
    Hat das AS-Template einen Override-Ordner ...htm/com_virtuemart? Einige AS-Templates habe ich ohne Overrides gesehen.
    Wenn dieser Ordner besteht, benenne ihn doch einmal um und versuche es noch einmal.

    PHP 7.1 einmal auf PHP 7.0 umzuschalten, könnte evtl. auch ein Ansatzpunkt sein.

    Beim Einloggen ins Backend fängt normalerweise mein kostenpflichtiger Support an, vielleicht schaffen wir es ja auch so.

    Grüße
    Stefan
    gizmo_m likes this.
    --
    Stefan Schumacher
    www.schumacher-netz.de
    VirtueMart Admin Template https://www.jooglies.com/virtuemart-...admin-template

    Im Forum gebe ich gerne öffentlich kostenlose Hilfestellung für allgemeine Probleme, wenn meine Zeit es zulässt.
    Diese Hilfe soll der Allgemeinheit zu Gute kommen und baut durch das Forum eine Wissensdatenbank für Antwortsuchende auf.
    Private Nachrichten bitte nur, wenn kommerzieller Support gewüscht wird; auch meine Zeit ist nur begrenzt.

  5. #5
    Erfahrener Benutzer
    Registriert seit
    06.05.2013
    Ort
    Lonavala
    Beiträge
    1.959
    PS. Die aktuell offiziell verfügbare Version VM 3.2.3.9587 hat sehr viele Bugfixes und Verbesserungen und ist problemlos zu installieren, wenn man keine Core-Overrides hat (was ja heute kaum mehr nötig ist).

    Files - VirtueMart

    Die würde ich einmal installieren.

    Grüße
    Stefan
    --
    Stefan Schumacher
    www.schumacher-netz.de
    VirtueMart Admin Template https://www.jooglies.com/virtuemart-...admin-template

    Im Forum gebe ich gerne öffentlich kostenlose Hilfestellung für allgemeine Probleme, wenn meine Zeit es zulässt.
    Diese Hilfe soll der Allgemeinheit zu Gute kommen und baut durch das Forum eine Wissensdatenbank für Antwortsuchende auf.
    Private Nachrichten bitte nur, wenn kommerzieller Support gewüscht wird; auch meine Zeit ist nur begrenzt.

  6. #6
    Neuer Benutzer Avatar von gizmo_m
    Registriert seit
    13.05.2016
    Beiträge
    8
    Hoi Stefan

    Erst mal vielen Dank für Deinen sensationellen Support

    Hab mir mal einen SQL-Export der Tabelle gemacht und dort alle Einträge in withParent und parentOrderable von 0 auf 1 gesetzt.
    Drop Table und neu importiert. TipTop
    Funzt wieder
    Vielen Dank dafür

    Zum 2. Problem hab ich 1. mit Akeeba ein komplettes Backup gemacht und dann die aktuellste VM installiert und PHP auf 7.0 umgestellt.
    Zusätzlich in VM Media-Dateien einen "Media Dateien synchronisieren" gemacht.
    Hat alles "noch" nichts gebracht.
    Dann hab ich den Override-Ordner umbenannt und siehe da. Es funzt wieder

    Ich frag mich nur, woran kann das liegen? Daran wurde ja nichts geändert.
    Kann das bei einem der VM-Updates geschehen sein?

    Ich dachte immer, Overrides sind genau dazu da, dass gewisse Einstellungen die man haben möchte bei einem Update NICHT überschrieben werden?
    Oder lieg ich da komplett falsch?

    Vielen Dank und Gruss aus der Schweiz
    Marcel

  7. #7
    Erfahrener Benutzer
    Registriert seit
    06.05.2013
    Ort
    Lonavala
    Beiträge
    1.959
    Servus Marcel,

    jain, Overrides sind dazu da, Änderungen beizubehalten, allerdings nicht für immer. Einige Templates benutzen immer noch Overrides, die auf VM 2 Code aufbauen, und da muss man dann bei den Template-Herstellern nachhaken, ob es eine angepasste Version gibt. Langsam wird alter Code aus VirtueMart rausgeworfen, so ist das nun einmal im Internet, Versionen bleiben nicht stehen, und auf PHP 5.3 aufgebaute Dinge, laufen unter PHP 7.x halt teilweise nicht mehr.

    Bei so Herstellern wie Olympianthemes oder VirtuePlanet muss man da nicht hinterherlaufen, bei AS bekomme ich immer nette Aufträge, alte Templates anzupassen. ;-)

    Grüße
    Stefan
    --
    Stefan Schumacher
    www.schumacher-netz.de
    VirtueMart Admin Template https://www.jooglies.com/virtuemart-...admin-template

    Im Forum gebe ich gerne öffentlich kostenlose Hilfestellung für allgemeine Probleme, wenn meine Zeit es zulässt.
    Diese Hilfe soll der Allgemeinheit zu Gute kommen und baut durch das Forum eine Wissensdatenbank für Antwortsuchende auf.
    Private Nachrichten bitte nur, wenn kommerzieller Support gewüscht wird; auch meine Zeit ist nur begrenzt.

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •