VirtueMart E-Mail Pro und VirtueMart Rechnung Pro
Ergebnis 1 bis 8 von 8
  1. #1
    Neuer Benutzer
    Registriert seit
    29.03.2017
    Beiträge
    4

    Frage NAch Update auf J 3.6.5 und VM 3.2.0 Auswahlen nur "eingeschränkt" möglich

    Hallo zusammen!

    Ich hatte schon ein wenig Probleme bei der richtigen Titel-Findung, denn...

    ich habe jetzt folgendes Szenario, dass ich wirklich absolut nicht verstehen oder nachvollziehen kann:

    1. unter J 3.6.2 und VM 3.0.18 lief alles problemlos.
    2. Update auf J 3.6.5 und VM 3.2.0 durchgeführt.
    3. PHP Version auf 7.1. angepasst.

    Hauptinstallation im Wurzelverzeichnis "html":

    Nur noch Produkte OHNE Produktvarianten lassen sich bestellen, bei allen anderen steht "Wählen Sie zuerst eine Produktvariante", allerdings lässt sich keine Variante auswählen.


    Zweite Installation im Verzeichnis "html/2":

    Produkte OHNE Produktvarianten lassen sich bestellen UND zusätzlich auch Produkte MIT Produktvarianten, die in einem Modul präsentiert werden (z.B. als "Aktionsprodukte"), aber NICHT das SELBE Produkt, dass man über die Navigation auswählt! Dort steht wieder nur "Wählen Sie zuerst eine Produktvariante" und es geht nicht weiter...

    Ich habe jetzt rumprobiert und rumprobiert, aber drehe mich mittlerweile gedanklich im Kreis und hoffe, dass mir hier jemand vielleicht DEN entscheidenden Denkanstoß geben kann...

    Wer sich das "Problem" einmal live ansehen möchte, findet hier die o.g. Zweitinstallation:
    http://www.besteckhalter.de/2/index.php

    VIELEN Dank vorab für jede Hilfe!

    Gruß Stefan
    Geändert von HPSH (29.03.2017 um 08:51 Uhr)

  2. #2
    Erfahrener Benutzer Avatar von faro
    Registriert seit
    10.01.2013
    Ort
    HRO
    Beiträge
    676
    Hallo Stefan,

    wann wurde denn das Update von J3.6.2 auf J3.6.5 gemacht? Versuche mal die PHP 5.6 zu nutzen. 7.1 ist sehr neu, und 7.0 generell zippelt hier und da noch etwas.

    Gruß Faro
    Geändert von faro (02.04.2017 um 18:18 Uhr)

  3. #3
    Neuer Benutzer
    Registriert seit
    29.03.2017
    Beiträge
    4
    Hallo Faro,

    vielen Dank für Deine Hilfe!

    Das Update habe ich gestern durchgeführt und habe gerade wieder auf die PHP-Version 5.6 downgegradet... - leider ohne sichtbare Veränderung!

    Was mich ja so "irritiert" ist, DASS bei einer Produktauswahl aus einem Modul heraus alles funktioniert - beim direkten Anwählen aber nicht! Also grundsätzlich scheinen die Funktionen ja da zu sein, aber sie greifen eben nicht immer...

    Gruß
    Stefan

  4. #4
    Erfahrener Benutzer Avatar von faro
    Registriert seit
    10.01.2013
    Ort
    HRO
    Beiträge
    676
    Hallo Stefan,

    die Version 3.6.2 wurde in der letzten Zeit sehr oft gehackt, da die Sicherheitsupdates 3.6.3 und 3.6.4 so im Dezember 1015 nicht eingespielt wurden. Teste deine Seite mal auf Schadecode oder eigenartige Dateien in den Ordnern. Zb. "libraries". Du kannst auch mal in deiner Benutzerverwaltung nachsehen, ob da User enthalten sind, welche Du nicht zuordnen kannst.

    Deine Problematik hatte ich vor einem halben Jahr bei einer Installation eines bekannten. Nach vielem hin und her, stellete sich die Installation leider als gehackt heraus.

    Muss bei Dir jetzt nicht so sein, aber besser erst mal nachsehen.

    Gruß Faro

  5. #5
    Neuer Benutzer
    Registriert seit
    29.03.2017
    Beiträge
    4
    Hallo Faro,

    ich habe zwar so etwas schon "befürchtet", aber bisher noch keine definitiven Hinweise dafür gefunden...

    Ich werde jetzt mal alle Dateien mit Kaspersky scannen und dann weitersehen!

    Ich habe übrigens gerade eben noch einmal eine Datensicherung aus 11/16 mit Kickstart in ein weiteres Unterverzeichnis zurückgespielt und weiß, dass NACH diesem Sicherungsdatum auch weiterhin Bestellungen (im Weihnachtsgeschäft) getätigt wurden!

    Auch DIESE Installation "zickt" jetzt herum... da ist doch irgendwo der Wurm drin! *kopfschüttel*

    Wäre die Installation gehackt worden, wären NACH dem Datum der Sicherung wohl keine Bestellungen mehr vorgenommen worden. Falls aber doch, so MÜSSTE m.E. die Sicherung, die ich jetzt zurückgespielt habe, doch auf JEDEN Fall einen ordnungsgemäßen Shop anzeigen, was aber eben nicht der Fall ist...

    Also irgendwie ist das Ganze doch SEHR mysteriös!

    Gruß
    Stefan

  6. #6
    Erfahrener Benutzer Avatar von faro
    Registriert seit
    10.01.2013
    Ort
    HRO
    Beiträge
    676
    Hallo Stefan,

    mit Kaspersty zu testen, ist nur eine kleine Möglichkeit. Es gibt php Codezeilen, welche ein Virenprogramm nicht erkennen kann.

    Auch geht es bei einem Hack nicht um die Seite in ihrer Funktion zu zerstören, sondern eher darum mit dieser Kompromitierten Spam zu versenden. Da funktionieren erfahrungsgemäß auch noch Bestellungen.

    Leider ist es so, dass wenn eine Seite lange ungeschützt im Netz ist, diese unter Ganoven auch mal schnell rumgereicht wird und jeder dann seinen Kram hinterlegt, bis es dann durch Fehlfunktionen auffällt. So kann es durchaus möglich sein, dass auch deine Sicherung schon befallen ist.

    Ich kann mich sehr gut an die beiden Sicheheitsupdates im Dezember 2015 erinnern, (3.6.3 und 3.6.4) da ging es leider um wenige Stunden, bis die Bad Boys nach veröffentlichung der Lücke zugeschlagen hatten.

    Aber nun teste mal erst mit Kaspersky und gib dann mal Bescheid.

    Gruß Faro

  7. #7
    Neuer Benutzer
    Registriert seit
    29.03.2017
    Beiträge
    4
    Hi Faro,

    wie erwartet hat der Scan mit Kaspersky kein negatives Ergebnis gebracht...

    Tja... und jetzt gehts erstmal an mein nächstes Problem: Die Datensicherungen (von "früher") liegen auf meinen NAS-Server, der seit Sonntag rumzickt und nicht mehr erreichbar ist... WENN, dann wieder mal ALLES auf einmal, kennt man ja... *ufff*

    Gruß, Stefan

  8. #8
    Super-Moderator Avatar von Milbo
    Registriert seit
    03.07.2012
    Beiträge
    1.002
    Also bei einer eventuell gehackten Seite muß man folgendes machen.

    Backup ziehen, zuhause auspacken, Kaspersky drüber laufen lassen. Der löscht dann befallene Bilder und ähnliches.

    Dann die gesamte Installation löschen, bis auf die configuration.php, die Images und Media.

    Dann die gesamte Seite neuaufziehen. Das heißt joomla auspacken,.. installations Ordner gleich löschen.

    und alles wieder drauf installieren, da die db die gleiche ist sollte alles wie ein update sein, dann hat man wieder alle Dateien im Original. Dann eye dingens installieren, das zeigt gleich an, welche Dateien sich verändert haben. Für die Zukunft, und dann zurückspielen. Dann kann man imho auch die DB einfach lassen,... und das gesamte Verzeichnis löschen und die sauberen Dateien per ftp hochladen (als zip und auspacken ist deutlich schneller)
    Project leader VirtueMart
    You may pay someone doing your store or learn it yourself, visit our bronze certification http://extensions.virtuemart.net/cer...ication-detail

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •