VirtueMart E-Mail Pro und VirtueMart Rechnung Pro
Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 22
  1. #1
    Administrator Avatar von Media-Service-Essen
    Registriert seit
    29.05.2011
    Ort
    Hier oder in Essen/Ruhr oder in Bochum
    Beiträge
    903

    Beitrag Installation Joomla 1.5., 1.6, 1.7: Mit PHP5 bei 1&1 installieren

    Die Installationsschritte sind genauso wie in meinen anderen Tutorials beschrieben.

    Vor der Installation müssen zwei wichtige Änderung in der ".htaccess" Datei vorgenommen werden, damit Sie bei Ihrem Hoster 1&1 die PHP5 Funktionen des Servers/Webspace nutzen können.

    Sollte die Datei bei Ihrer Joomla-Installation noch "htaccess.txt" heißen, dann benennen Sie diese nun mit einem FTP-Pogramm in ".htaccess" um. Rufen Sie die Datei anschließend zur Bearbeitung auf. Fügen Sie folgende Zeilen ein:

    Code:
    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php
    Sie sehen weiter unten in der ".htaccess" den Eintrag "# RewriteBase /". Hier ist die "#" zu entfernen, so dass die Zeile dann wie folgt aussieht:

    Code:
    RewriteBase /


    Gerade am Anfang, wenn man bei 1&1 vielleicht zum ersten Mal eine Joomla-Installation durchführt, tauchen derartige "Probleme" auf. Daher noch hier eine Erläuterung zum Hintergrund der oben aufgeführten Änderungen:

    Die erste Änderung oben sorgt dafür, dass 1&1 Ihre Joomla-Installation mit der Serverscriptsprache PHP5 laufen lässt.

    Die zweite Änderung ist so zu verstehen: Das Heimatverzeichnis Ihrer Joomla-Installation liegt genau in dem Ordner, auf den Ihre Domain verweist. Ein praktisches Beispiel dazu: Ihre Domain lautet: "www.hans-mustermann.de". Und Ihre Joomla-Installation befindet sich auf Ihrem Webspace im Ordner "/joomla". In Ihrem Kundenmenü bei 1&1, unter den Domaineinstellungen, legen Sie fest, dass "www.hans-mustermann.de" als Webspace verwendet wird und das Heimatverzeichnis "/joomla" lautet.
    Geändert von Media-Service-Essen (11.11.2012 um 10:28 Uhr)
    Mit besten Grüßen. Michael Schulze, Media-Service-Essen - VirtueMart.de
    Problem gelöst?
    Dann bitte auch die Lösung posten und den Beitrag auf [gelöst] setzen.
    Hierzu im ersten Beitrag oben links auf "Dieses Thema als [GELÖST] markieren" klicken.

    Dienstleistung: VirtueMart Demo Shop | Online Demo - Freie Services: VirtueMart Forum | Starter Edition
    Premium Pro Services: Support VirtueMart Demo Shop | Videoanleitungen VirtueMart 2 und Joomla!

  2. #2
    Neuer Benutzer
    Registriert seit
    18.11.2011
    Beiträge
    5

    Installation 1.7 bei 1&1 hängt bei Sprachauswahl

    Hallo Zusammen,
    habe bei der Neuinstallation von J1.7 ein Problem. Bekomme bei Aufruf des Webverzeichnissen folgende Meldungen:

    Strict Standards: Declaration of JInstallation::initialise() should be compatible with that of JApplication::initialise() in /homepages/35/d38247460/htdocs/Joomla 17/installation/includes/application.php on line 365

    Strict Standards: Declaration of JInstallation::_createConfiguration() should be compatible with that of JApplication::_createConfiguration() in /homepages/35/d38247460/htdocs/Joomla 17/installation/includes/application.php on line 365

    Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /homepages/35/d38247460/htdocs/Joomla 17/installation/includes/application.php:365) in /homepages/35/d38247460/htdocs/Joomla 17/libraries/joomla/session/session.php on line 462

    Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /homepages/35/d38247460/htdocs/Joomla 17/installation/includes/application.php:365) in /homepages/35/d38247460/htdocs/Joomla 17/libraries/joomla/session/session.php on line 462



    Nach den Meldungen kommt das Installationsfenster mit der Sprachauswahl. Nach Klick auf weiter erscheint ein "Ladekreisel". Auch nach längerem Warten passiert leider nichts mehr.

    Habe im gegoogelt und hier den Hinweis auf die .htaccess datei gefunden und
    die Einträge AffType und Addhandler in die Datei eingetragen und die Korrektur Rewritebase vorgenommen.

    Leider nicht geholfen. Habt ihr noch eine Idee?

    Sonnige Grüße Norbert

  3. #3
    Administrator Avatar von Media-Service-Essen
    Registriert seit
    29.05.2011
    Ort
    Hier oder in Essen/Ruhr oder in Bochum
    Beiträge
    903
    Sind Sie bei 1&1 mit Ihrer Joomla-Installation? Ich vermute, trotz Ihrer bisherigen Bemühungen, dass die .htaccess noch nicht richtig ist. Für eine Lösung müsste ich den Inhalt mal sehen können.
    Mit besten Grüßen. Michael Schulze, Media-Service-Essen - VirtueMart.de
    Problem gelöst?
    Dann bitte auch die Lösung posten und den Beitrag auf [gelöst] setzen.
    Hierzu im ersten Beitrag oben links auf "Dieses Thema als [GELÖST] markieren" klicken.

    Dienstleistung: VirtueMart Demo Shop | Online Demo - Freie Services: VirtueMart Forum | Starter Edition
    Premium Pro Services: Support VirtueMart Demo Shop | Videoanleitungen VirtueMart 2 und Joomla!

  4. #4
    Neuer Benutzer
    Registriert seit
    18.11.2011
    Beiträge
    5
    Hallo MSE,
    habe ihnen gerade meine htaccess Datei geschickt. Habe wahrscheilich das Problem schon gelöst. habe die EInstellung bei PHP von phpdev auf php5 geändert und jetzt öffnet das Installationsfenster ohne Fehlermeldung und nach weiter kommt direkt der nächste Installationsschritt.
    Werde die Installation jetzt nach ihrer Anleitung weiter durchführen und dann berichten ob alles funktioniert hat.

  5. #5
    Neuer Benutzer
    Registriert seit
    18.11.2011
    Beiträge
    5
    Hallo MSE,
    schon stosse ich auf das nächste Problem. Die Verbindung mit der DB kann nicht hergestellt werden (Es konnte keine Verbindung zur Datenbank hergestellt werden! Der Konnektor gab folgenden Fehler zurück: 2).
    Habe in meinen 1&1 Sql DB Einstellungen den DB Namen und Benutzernamen kopiert und im Installationsfenster eingefügt. Müsste also korrekt sein. Habe das Passwort nochmal geändert und 100% sicher zu sein, das ich das richtige verwende. Habe einmal mit Servername "localhost" und einmal mit dem Hostname der bei der 1&1 DB steht getestet. Leider ohne Erfolg.
    Habe die DB angelegt, weil ich sie für Joomla 1.5 nutze. Kann die DB vielleicht nur "einmal" Joomla. Sorry, habe bei DB leider garkeine Erfahrung/Ahnung.
    Sonnigen Gruß Norbert

  6. #6
    Neuer Benutzer
    Registriert seit
    18.11.2011
    Beiträge
    5
    Hallo MSE,

    habs geschafft. Habe den Hostnamen, der bei 1&1 hinterlegt ist in das Eintragfenster Servername anstelle von Localhost eingetragen.
    Hatte beim ersten Versuch vielleicht eine der anderen Einträge falsch gehabt.
    Vielen Dank für die Unterstützung. Besonders auch für die hilfreichen Videos und Tutorials.
    Kann jetzt loslegen, bin schon sehr gespannt

    Sonniges Wochenende
    Norbert

  7. #7
    Administrator Avatar von Media-Service-Essen
    Registriert seit
    29.05.2011
    Ort
    Hier oder in Essen/Ruhr oder in Bochum
    Beiträge
    903
    Hallo Norbert, bei Art der MySQL-Verbindung wählen Sie für Joomla 1.7: "MySQLi". Sie liegen richtig: Übertragen Sie für Hostname, Benutzername, Datenbankname und Passwort jeweils die Ihnen bekannten Daten. Auf diese Weise sollte das funktionieren.
    Ich kann mir Ihre .htaccess erst später am Abend ansehen. Ggf. helfe ich Ihnen mit einer kurzen Fernwartung über das Problem hinweg. Bitte legen Sie für jede Joomla-Installation der Übersicht halber eine eigene Datenbank an.
    Unter der Rubrik "Blogs" können Sie über meine Website mit mir später im Bedarfsfall chatten und mir eine Fernwartung ermöglichen. Sie finden dort rechts die entsprechenden Schaltflächen.
    Übrigens: Ich freue mich immer über Rückmeldungen und Anregungen. Nutzen Sie bitte die Kommentarmöglichkeiten auf meiner Website und auch bei Youtube wenn Sie mögen! Sie helfen mir dadurch auch, meine Services zu verbessern.
    Mit besten Grüßen.
    Mit besten Grüßen. Michael Schulze, Media-Service-Essen - VirtueMart.de
    Problem gelöst?
    Dann bitte auch die Lösung posten und den Beitrag auf [gelöst] setzen.
    Hierzu im ersten Beitrag oben links auf "Dieses Thema als [GELÖST] markieren" klicken.

    Dienstleistung: VirtueMart Demo Shop | Online Demo - Freie Services: VirtueMart Forum | Starter Edition
    Premium Pro Services: Support VirtueMart Demo Shop | Videoanleitungen VirtueMart 2 und Joomla!

  8. #8
    Neuer Benutzer
    Registriert seit
    18.11.2011
    Beiträge
    5
    Hallo MSE,
    vielen Dank für ihre schnelle Antwort, habe Installation hinbekommen.
    Wünsche ihnen einen geruhsamen und (ent)spannenden Samstagabend
    Sonnigen Gruß Norbert

  9. #9
    Neuer Benutzer
    Registriert seit
    24.11.2011
    Beiträge
    4
    Zitat Zitat von Media-Service-Essen Beitrag anzeigen
    Die zweite Änderung ist so zu verstehen: Das Heimatverzeichnis Ihrer Joomla-Installation liegt genau in dem Ordner, auf den Ihre Domain verweist. Ein praktisches Beispiel dazu: Ihre Domain lautet: "www.hans-mustermann.de". Und Ihre Joomla-Installation befindet sich auf Ihrem Webspace im Ordner "/joomla". In Ihrem Kundenmenü bei 1&1, unter den Domaineinstellungen, legen Sie fest, dass "www.hans-mustermann.de" als Webspace verwendet wird und das Heimatverzeichnis "/joomla" lautet.
    Ich habe bei einer Joomla 1.5 Installation bei 1&1 meine Daten in ein Unterverzeichnis joomla/ gelegt. Als ich jetzt im Kundenmenü die Hauptdomain auf dieses Unterverzeichnis geleitet habe, weil ich online gehen wollte, musste ich feststellen, dass die Pfade alle nicht mehr stimmen. Außer der index wird nichts mehr gefunden. Bei anderen Providern war dieser Schritt nie ein Problem. Ich bin ratlos. Ein Versuch, die configuration.php und die .htaccess anzupassen, ist gescheitert. Ich bin für jeden Hinweis sehr dankbar.

    mathilda

  10. #10
    Administrator Avatar von Media-Service-Essen
    Registriert seit
    29.05.2011
    Ort
    Hier oder in Essen/Ruhr oder in Bochum
    Beiträge
    903
    Hallo Mathilda, herzlich willkommen Mein Tutorial beschreibt hier die Installation von Joomla im Zusammenhang mit der Domainzuordnung bei 1&1. Ihr Problem hat sich daraus ergeben, dass Sie eine bestehende Joomla-Installation nunmehr in ein Unterverzeichnis oder anderes Verzeichnis verschoben haben. So habe ich das jedenfalls verstanden.
    Ohne weitere Informationen zu dem, was Sie bisher gemacht haben, kann man sich nur in Ihre Nähe hin raten. Es wäre hilfreich zu erfahren, ob die Installation woanders lief (anderer Provider?) und ob Sie alles mit FTP auf Ihren neuen Webspace gebracht haben (da geht meistens was schief beim manuellen Kopieren von tausenden Dateien ohne das Sie was davon merken). Bei weiteren Infos gebe ich gerne eine Hilfestellung. Ggf. sehe ich mir auch die Dateistruktur und die Konfiguration per Fernwartung an, sofern Sie das Problem nicht gelöst bekommen.
    Mit besten Grüßen.

    Update: Und denken Sie bitte an die Modifizierung der .htaccess sowie die Einstellung in Ihrem FTP-Programm, dass Dateien im Binär-Modus zu kopieren sind.
    Mit besten Grüßen. Michael Schulze, Media-Service-Essen - VirtueMart.de
    Problem gelöst?
    Dann bitte auch die Lösung posten und den Beitrag auf [gelöst] setzen.
    Hierzu im ersten Beitrag oben links auf "Dieses Thema als [GELÖST] markieren" klicken.

    Dienstleistung: VirtueMart Demo Shop | Online Demo - Freie Services: VirtueMart Forum | Starter Edition
    Premium Pro Services: Support VirtueMart Demo Shop | Videoanleitungen VirtueMart 2 und Joomla!

Seite 1 von 3 123 LetzteLetzte

Ähnliche Themen

  1. [Video] Joomla 1.7 offline installieren - XAMPP Installation
    Von Media-Service-Essen im Forum Installation & Updates
    Antworten: 2
    Letzter Beitrag: 10.02.2012, 12:36
  2. [Video] Virtuemart 2.0 mit Joomla 1.7 Basispaket VM 2.0 und deutsche Sprachdatei installieren
    Von Media-Service-Essen im Forum Installation, Updates und Einrichtung
    Antworten: 0
    Letzter Beitrag: 09.11.2011, 02:11
  3. [Video] Joomla 1.7 offline installieren - Akeeba Kickstart - XAMPP lokale Installation
    Von Media-Service-Essen im Forum Installation & Updates
    Antworten: 0
    Letzter Beitrag: 15.09.2011, 01:07
  4. [Tutorial] Joomla 1.7 installieren
    Von Media-Service-Essen im Forum Nützliches zu Joomla
    Antworten: 0
    Letzter Beitrag: 17.08.2011, 23:59
  5. [Tutorial] Joomla! 1.5 installieren
    Von Media-Service-Essen im Forum Nützliches zu Joomla
    Antworten: 0
    Letzter Beitrag: 17.07.2011, 11:37

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •