Beiträge von silgra

    Servus Stefan, danke für Deine Antwort.

    Stimmt, ich habe das Produktmodul für jede Kategorie erstellt und es dem jeweiligen Menüpunkt zugeordnet. Und es stimmt auch, dass dadurch der Artikel doppelt angezeigt wird.

    In das Feld "Verwandte Produkte" kann ich die Artikel nicht alle einzeln hinzufügen, da ja ständig neue hinzukommen. Es müsste aber diese Darstellung sein - nur automatisch eben. Das Feld "Verwandte Kategorie " wäre TippTopp - nur zeigt es da die Kategorie als Text. Es sollten aber gleich die Produkte zu sehen sein.

    2 Fragen:

    Wie wäre der Code für das Override? Dieser müsste in die productdetails ->details.php, stimmts? Würdest Du mir den Code sagen, bitte, damit ich das erstellen kann?

    Und die zweite Frage wäre, wie filtert man im Produktmodul das angezeigte Produkt heraus? Ich habe bei den Einstellungen unter "Auslassen" JA gesetzt. Das Produkt ist aber immer noch da.


    silgra: "ich möchte gerne unter der Detailanischt eines Produktes, weitere Artikel der gleichen Kategorie anzeigen lassen."

    Deine Fragestellung war etwas ungenau, weil das, was Du in der Frage schreibst, hast Du ja schon.

    Stimmt auch, nur sollten die Produkte der gleichen Kategorie automatisch angezeigt sein, ohne das ich ein Modul dafür erstellen muss. Im Prinzip "Verwandte Kategorie" nur in bereits geöffnet.


    Wäre toll, wenn Du helfen könntest.

    Liebe Grüße, Silke

    Servus zusammen,

    ich möchte gerne unter der Detailanischt eines Produktes, weitere Artikel der gleichen Kategorie anzeigen lassen.

    Beispiel: Kategorie Jeans
    Übersichtseite zeigt alle Jeans (das passt so)
    Nun klickt man auf eine Jeans (Detailansicht). Jetzt sollen hier bitte nach der Ansicht "Mehr Jeans" angezeigt werden. Ähnlich wie Verwandte Kategorien. Ich brauche aber die Produkte der Kategorie ...

    Ich habe das bisher mit ohne Ende vielen Modulen gelöst, die ich unterhalb eingeblendet habe. Es sind zu jeder Kategorie Menüpunkte angelegt.


    Ist es möglich sowas "zentral" zu steuern, dass immer noch weitere Produkte dieser Kategorie angezeigt werden und das aktuell geöffnet Produkt aber nicht mehr angezeigt wird?

    Danke für Hilfe oder Tipps, liebe Grüße, Silke

    Servus Stefan, danke für die schnelle Antwort! Auch danke für den Hinweis mit der Zahlungsart. Dort stand VM Payment - Standard.

    Außerdem war dort, im Tab Konfiguration, bei "Bestellstatus für noch ausstehende Zahlungen" VOM KUNDEN BESTÄTIGT ausgeüllt.

    Am Ende des Konfikurationstabs stand bei MwSt "Keine Regel" Ich habe dies jetzt umgestellt auf 19% und nun funktionierts mit der Bestellbestätigung.

    Vielen Dank nochmal! Weißt was ich nicht verstehe ... bei den anderen Shops steht bei MwSt KEINE REGEL und die Bestellbestätigungen kommen an. Selbes System, selbes Template, selbe Versionen ...

    Servus zusammen,

    ich brauche bitte heute wieder Eure Hilfe. Es ist nicht zufassen - ich habe mittlerweile 5 VM Shops am Laufen - alle haben die geichen Einstellung, damit ja alles läuft ... nun beim Neusten VM Shop, werden die Bestätigungsmails nicht verchickt.

    Ich weiß, dass die mit dem Bestellstatus was zu tun hat - der steht leider auf "In Bearbeitung" statt auf "Vom Kunde bestätigt".

    Zahlungsart ist VM Payment - Standard

    Unter Konfiguration -> Bestellung steht der Standard-Bestellstatus auf "Vom Kunden bestätigt".

    Warum passts denn bei diesem Shop nicht? Was habe ich denn falsch eingestellt.

    Könnt Ihr mir helfen? ♥ Danke, liebe Grüße, Silke

    ... ich habe rausgefunden, dass wenn ich im Menüpunkt "Produkte anzeigen" auf NEIN stelle (siehe Anhang), kommt die fehlerhafte Sprache.

    Es handelt sich um die Erste (obere) Kategorieebene. Klickt man dort drauf, sollen alle Unterkategorien aufgezeigt werden - aber keine Produkte. Deswegen stelle ich "Produkte anzeigen" auf NEIN. Diese Aktion ruft aber den Sprachangabefehler (Sprache GL) hervor.

    Müsste ich noch wo anders etwas ausschalten, damit Sprachangabe in der Kategorieübersicht stimmt?

    Edit: Stimmt nicht, die fehlerhafte Sprachangabe kommt auch wenn "Produkte anzeigen" auf JA steht.
    Kann das ein Bug sein? Was mach ich nur falsch? Bei manchen Kategorien geht es, bei manchen nicht.

    Servus zusammen,

    eben habe ich bemerkt, dass die im text erkannt Sprache GL ist (was auch immer für ein Land das ist). Dieser fehler kommt nur bei VirtueMart.

    Im Anhang habe ich zwei Bildschirmaufnahmen von meinen Einstellungen gemacht. Kann mir bitte jemand weiterhelfen, was ich wieder falsch gemacht habe?

    Joomla ist 3.9.24. VM 3.8.8, VM Sprachdatei 3.8.9.0

    Edit: Ich habe rausgefunden, dass dies immer auftritt, wenn im Menüpunkt die Hauptkategorie aufgerufen wird. Bei den dazugehörigen Unterkatgegorien stimmt die Sprache (deutsch).

    Liebe Grüße, Silke

    Servus zusammen, Servus Stefan,

    ich bräuchte heute wieder mal Hilfe, komme leider nicht selber drauf.

    Wokann ich einstellen, dass der Rabatt nicht in EURO sonder in Prozent angezeigt wird? Z.B. Preis 15,90 €, reduzierter Preis: 14,31 €, Rabatt 10% (nicht 1,59 €)


    Schon mal vielen Dank für Eure Hilfe, Silke

    Servus zusammen,

    ich möchte zwei verschiedene Versandarten zur Auswahl geben - eine kostenlose ABHOLEN (click&collect) und eine kostenpflichtige LIEFERUNG.


    Nicht ganz unstolz kann ich behaupten: Das habe ich hinbekommen und es läuft! :-)

    Nun brauche ich aber denoch Eure Hilfe.

    Ist es möglich, das beide Versandarten direkt angezeigt werden, ohne das man erst auf "Versandart wählen" klicken muss und dadurch auf eine neue Seite (oder Popup) geleitet wird. Ich hätte das gerne offen da stehen und würde gerne die rumklickerei weglassen. Geht das irgendwie?

    Ich freue mich über Eure Hilfe und sag schon mal Danke, Silke

    Hallo zusammen, es funktioniert bei 7 installierten Shops nicht.

    Ich habe jetzt die 3.8.4 bei der Kundin drüber gespielt. Nun funktioniert der Shop auch wieder. Danke Stefan!

    An Faro:
    "Dieser Fehler kann auch ein Datenbankproblem sein. Wie hast Du diese unterschiedlichen Shops erstellt? Sind es eventuell Kopien von einer Installation? Haben sie unterschiedliche Datenbanken?"
    Ja die Shops haben unterschiedliche Datenbanken. Es sind keine Kopien von einer Installation. Virtuemart wurde installiert und dann immer geupdatet.


    "Was genau bedeutet, "konnte Backup nicht einspielen?" Es war das 4. Update und nur 3 sind aktiv.

    Nun laufen alle Shops wieder - jedoch kann ich nicht updaten, da es zu 1054 Fehler kommt. Kann man irgendwo sehen, durch was der 1054 Fehler entsteht?

    Ich bin erstmal erleichtert, dass die Kunden arbeiten können, gelöst ist mein Problem aber nicht :-(



    Hi Faro, ich habe bei dem einen Kunden jetzt das Backup wieder eingespielt. Somit können die arbeiten.

    Ich nutze extern Custom Fields (v.4.1.0) for all und Stockable Customfields (v.1.5.1). Ich weiß nicht was WaWi ist - meinst Du Warenwirtschaftssystem?

    Mit der version 3.8.6.funktioniert auch die Produktsortierung nicht mehr und es kommt zum 1054 Fehler. Auch die Seitennavigation - klicke ich bei Produkte auf Seite 2 kommt es wieder zu einem 1054 Fehler. Ebenso kann ich die Produktkategorien nicht mehr nach Reihenfolge sortieren.

    Joomla ist auf 3.9.22, PHP 7.4.

    Kannst Du damit was anfangen?

    Servus zusammen, seit dem VM Update 3.8.6 kann ich die Produkte nicht mehr aufrufen und7oder sortieren. Daraufhin erscheint dieser Fehler:

    "Es ist ein Fehler aufgetreten! 1054 Unknown column 'Array' in 'where clause"

    Hier läuft gerade das telefon heiß, da mehre Kunden keine Artikel hochladen können.


    Weiß jemand an was das liegt?

    Danke für eine Antwort

    Servus,

    ich brauche nochmal Eure Hilfe, ich komme einfach selber nicht drauf.

    Ich möchte gerne in der Kategorieübersicht den "In den Warenkorb" Link zur Detailansicht verlinken und nicht direkt zum Checkout.

    Im Moment habe ich da zwei Buttons - einen "Details" und einen "In den Warenkorb" Ich möchte aber nur einen Button haben.

    Es soll deswegen der "In den Warenkorb" Button sein, weil damit die Größen und Farben verbunden sind. Würde ich diesen Button im Override auskommentieren, sind auch die größen und Farben weg.

    Kann jemand helfen?