Beiträge von BlueOwl

    Hallole!


    In der pdf-Rechnung, die generiert wird, werden die Produktattribute leider ueber dem Produktnamen plaziert. Siehe screenshot



    das ganze wird ja in der invoice_items.php generiert und habe da auch ein override. Das Problem ist, ich krieg die Anzeige im pdf einfach nicht klar. Habe den code schon dahingehend angepasst:


    PHP
    1. <td align="left" colspan="2" >
    2. <div style="display:block;"><a href="<?php echo $product_link; ?>"><?php echo $item->order_item_name; ?></a></div>
    3. <?php
    4. if (!empty($item->product_attribute)) {
    5. if(!class_exists('VirtueMartModelCustomfields'))require(JPATH_VM_ADMINISTRATOR.DS.'models'.DS.'customfields.php');
    6. $product_attribute = VirtueMartModelCustomfields::CustomsFieldOrderDisplay($item,'FE');
    7. echo '<p>'.$product_attribute.'</p>';
    8. }
    9. ?>
    10. </td>


    Wenn ich mir das ganze aus dem Backend per "Druck" anschaue, wird auch eine neue Zeile generiert, aber nur in dem pdf nicht. ??


    Die andere Änderung in der Spalte davor (kleines padding nach rechts) hat gut geklappt.


    Habe ich hier noch was uebersehen?


    (Joomla 2.5.24 und VM 2.6.10)

    Ist das vielleicht das Rundungsproblem? Damit kämpfe ich nämlich auch gerade, ich geben in den Versandkosten korrekt 14.28571 ein, wähle die Steuer, in Brutto steht richtig 17.
    Wenn ich mir das allerdings im Warenkorb ansehe, stehen dort 17,01 weil es von dem gerundeten Nettobetrag von 2,71 gerechnet wird. Da fehlen einfach nachkommastellen damit das richtig gerechnet werden könnte


    Im englischen Forum gibts dazu diesen Thread:


    http://forum.virtuemart.net/index.php?topic=111435.0


    Dort steht man könnte das durch eine Änderung in der administrator/components/com_virtuemart/helpers/calculationh.php ändern. Dort finde ich diese Zeile aber nicht, und ich frage mich ob das in den neuesten Versionen wirklich noch nicht korrigiert ist?


    PS: nutze dieses kleine helferlein: http://www.umsatzsteuer-rechner.de/

    *schubs*


    Also habe nochmal eine frische Kopie des 22b gezogen auf localhost. Dort taucht der Fehler nicht auf.


    Dieses Problem wurde in den diversen Threads auch im englischen Forum schon behandelt, allerdings hilft keiner der Lösungsvorschläge, die ich ausprobiert habe (verlauf, s.o.)


    Nachtrag:


    Habe nun mit einer frischen lokalen Kopie den Prozess nochmal durchgearbeitet, diesmal Schrittweise


    22a -> 22e -> 24 -> 26


    Diesmal kam bei der Testbestellung nach der 26 keine merkwuerdige Fehlermeldung mehr ... komisch :confused:

    Hallochen!


    Ich wuerde gerne unseren Shop updaten, erhalte aber beim Test folgende Fehlermeldung nach der Bestellung im Frontend:


    "Mindestens eine Empfänger-E-Mail-Adresse muss ausgewählt werden!"


    Update wurde gemacht von 2.0.22b auf 2.0.26d ueber den Joomla installer auf Localhost. Habe noch das aktuelle Sprachpaket nachinstalliert.


    Im Backend von Virtuemart sind folgende Einstellungen drin:


    Shop -> Kasseneinstellungen -> Email korrekt drin wie es sein soll
    System-Emails empfangen: "ja"


    Bei Konfiguration -> Shop habe ich testweise bei den Email-Einstellungen folgendes aktiviert:


    E-Mail Adresse des Verkäufers verwenden -> Ja


    hat nich geholfen.


    Bei den Kasseneinstellungen habe ich testweise in der Box:


    Standard-Bestellstatus, bei welchem eine E-Mail an den Verkäufer versendet wird


    "pending" aktiviert, nun wird bei der Testbestellung unterhalb der oben genannten Meldung noch:


    Mitteilung gesendet an test, test


    angezeigt? Die Meldung heisst doch, das ich aktiviert habe, das dem Käufer eine Email gesendet wird, aber nicht dem Verkäufer. Eigentlich war es doch andersrum gedacht.



    Wenn ich im Backend nun die Bestellungen bearbeite, und von pending auf confirmed setze, kommt folgende Meldung:


    Mindestens eine An: E-Mail-Adresse angeben.

    Habe im Backend noch bei Shop -> Zusatzinformationen :


    Ich stimme den Allgemeinen Geschäftsbedingungen zu


    ein Haken gesetzt, hat nich geholfen.


    Wo kann ich denn noch nachschauen?

    Dank dir!


    Das ist ein Weg ja, aber ich hätte schon gerne die Links.


    Das Problem ist anscheinend, das die Produkt Navigation immer nach dem Namen sortiert (?) und nicht nach der Einstellung im Backend.


    Hier einige englische Threads dazu: (ohne Antworten)


    http://forum.virtuemart.net/in…13872.msg383182#msg383182


    http://forum.virtuemart.net/in…10208.msg369293#msg369293


    Weiss denn jemand welcher Codeteil dafuer verantwortlich ist?

    Hallo!


    Ich hab da mal ein Problem mit der Sortierung. Im Virtuemart habe ich angegeben, das die Kategorien nach "sortierung" angezeigt werden soll. Dann habe ich die Produkte im Backend sortiert.


    Nun werden sie im Frontend richtig angezeigt, aber sobald ich das erste Produkt anklicke, kann ich nicht das nächste Produkt ueber den Pfeil oben rechts auswählen, sondern ein anderes.


    Ein live Beispiel:


    Bobi Ersatzteile und Zubehör


    Klickt mal bitte auf "Lasergravur auf RSV-Einwurfklappe". Anstatt oben nur ein Pfeil zum nächsten Produkt zu sehen, welches ja "Hausnummer Colu..." sein sollte, sehe ich mehrere Pfeile auf ganz andere Produkte


    Den Cache habe ich schon gelöscht vom Joomla und vom Browser, wobei ich mir das als Fehlerquelle nicht denken kann.


    Woran kann es liegen?

    Also bei unserer Installation ist die Beschreibung der Kategorie standardmässig oberhalb der Produkte.


    Aber du meinst sozusagen eine "Oberbeschreibung", also eine beschreibung aller deiner Kategorien? Soweit ich weiss gibts in Virtuemart das nicht, aber das wurde ich mit einem Joomla HTML-Freitext Modul lösen, und dieses nur bei dem Link zum Shop anzeigen lassen. Somit sollte der Freitext ueber deinen Kategorien angezeigt werden.


    Falls dein Template keine solche Modulposition hat, fällt mir nur ein das man diese eben selbst einfuegen sollte.

    Vielen vielen Dank!


    Das ist wirklich super, hat prima geklappt!


    Im deutschen heisst die Einstellung in der Kategorie "Kategorie Formular Startzahl anzuzeigender Einträge"


    Wems zu umständlich ist, alle Kategorien durchzuklicken (so wie mir) kann die Einstellung auch direkt in der DB ändern.


    Einloggen in die DB, und folgenden SQL-Befehl ausfuehren:


    SQL
    1. UPDATE `j25_virtuemart_categories` SET `limit_list_initial` = '24'


    Den Wert '24' natuerlich mit der gewuenschten Menge ersetzen.


    Achtung: Immer zuerst ein Backup machen! - Der Befehl setzt alle Kategorien auf den neuen Wert!

    Vielen Dank fuer deine Antwort!


    Bei "Standard Anzahl der Produkte pro Reihe" steht eine 2. Es ist ja auch richtig so, da 2 Produkte in der Reihe stehen sollen. :confused:


    Meinst du hier vll eine andere Einstellung? In der Kategorie kann man folgendes einstellen:


    Standard Anzahl der Produkte pro Reihe
    Kategorie Formular Listenlimit Start
    Kategorie Formular Listenlimit Schrittgrösse
    Kategorie Formular Listenlimit max.
    Kategorie Formular Startzahl anzuzeigender Einträge


    Hat doch alles nichts mit der Einstellung der Produkte pro Seite zu tun?


    Habe aber hier bereits alle Einträge ausprobiert, hat keine Wirkung auf die Anzahl der Produkte pro Seite. Wirklich merkwuerdig.

    Eine bessere Beschreibung der Ausgangslage wäre hilfreich.


    Welche Virtuemart und Joomla Version nutzt du? Welches Joomla Template? Benutzt du Template overrides oder ist da noch alles wie am Anfang?