TCPDF-Fehler: The XObject Template '-1' doesn't exist!

  • Grüß Gott zusammen,


    ich bin mit Joomla 3.4.1 und VM 3.0.6 ( Glockenbach-Laden) unterwegs und habe erst kürzlich von Joomla 2.8.x auf die 3er Version upgedated. Nach ein paar Anpassungen läuft auch VM jetzt reibungslos, bis auf das Erzeugen von PDF-Dokumenten. Der Ordner "libraries/tcpdf" besteht, aber ich erhalte bei dem Versuch, eine Vorschau auf die PDF-Dokumente zu erhalten, den Fehler "TCPDF ERROR: The XObject Template '-1' doesn't exist!"


    Mit dem kann ich nun leider überhaupt nichts anfangen und hoffe, jemand unter Euch Cracks weiß Abhilfe.
    Vielleicht liegt es an den Zugriffsrechten des Ordners?
    Ich habe versucht, tcpdf 6.2.6 zu installieren und das System rödelt sich tot. Allerdings habe ich den bestehenden Ordner "libraries/tcpdf" vorher nicht gelöscht, wollte drüberinstallieren.


    Lieben Dank an alle!
    Eure Karin

  • Mahlzeit,


    seit der Version 3.0.6 wurde die TCPDF Funktion in eine externe Komponenete in der Version 1.0.0 ausgelagert. Hier kannst Du diese Downloaden und einfach über den Installer Installieren.


    Danach sollte wieder alles wie gewohnt Funktionieren.


    Gruß Faro

  • Hallo,


    ich habe ein ähnliches Problem.


    Und zwar Joomla 2.5.19 und Virtuemart 2.6.22 wenn ich unter Bestellungen "Lieferschein" oder "Rechnung" anklicke kommt die Meldung: TCPDF ERROR: The XObject Template '' doesn't exist!


    Der Button Drucken funktioniert und ich bekomme die PDF.


    Bevor es zu der Fehlermeldung gekommen ist habe ich eine Error 500 Fehlermeldung bekommen woraufhin ich die com_tcpdf_1.0.0 installiert habe nun kommt wie gesagt der oben beschriebene Fehler.


    Was kann ich dagegen tun.


    Vielen Dank schon einmal.


    Gruß Matthias

  • Hallo Matthias,


    Du hast das tcpdf auf eine sehr alte VM-Version installiert. Das wird so nichts. Auch dein Joomla selbst ist sehr, sehr, sehr alt 2.5.19 ist glaube ich aus 2013 und hat erhebliche Sicherheitslücken.


    Du solltest es, wenn es nicht schon gehackt wurde, auf 2.5.28 inkl. Sicherheitspatch bringen und danach gleich auf 3.5.1


    Auch VM ist momentan bei 3.0.16 Ich denke, wenn Du das alles realisiert hast, ist auch deine Fehlermeldung verschwunden.


    Gruß Faro

  • Servus,


    Du könntest versuchen, unter libraries den Ordner tcpdf zu löschen, und die alte Version aus einem VM-Installationspaket zu installieren. Das könnte das Problem beheben.


    Wie Faro schon gesagt hat. Mindestens eine Aktualisierung von Joomla auf 2.5.28 plus Sicherheitspatch vom 21.12.2015 ist angesagt, sonst ist der Shop jederzeit offen für Hackerattacken.


    Wenn der Shop auf J 2.5.28+ und VM 2.6.22 steht, ist er erst einmal "sicher", allerdings ist es langsam an der Zeit, über die weitere Aktualisierung nachzudenken. Auf einer Spiegelung ist das evtl. schnell erledigt. Kommt natürlich auf die Komplexität und die Anpassungen im Shop an.


    Grüße
    Stefan

  • Hallo Faro und Stefan,


    vielen Dank für euer Feedback.


    Habe nun Joomla wie von euch empfohlen auf 2.5.28 hoch gezogen und VM ist wie zuvor bei 2.6.22.
    Leider hat das mein Problem nicht behoben.


    Das Angesprochene Sicherheitspatch vom 21.12.2015 wo finde ich das?


    Ich denke das beste wird es sein das ich mit Joomla und VM auf Version 3 gehe dazu komme ich aber leider erst in gut 4 Wochen bis dahin muss es dann mal so weiter laufen.


    Vielen Dank schon einmal.