Beiträge von faro

    Hallo jumbo,


    ich denke, dass ist abhängig vom Template. Ich selbst habe mich nach einigen versuchen nun doch für die Templates von "VP" entschieden und bin nach ein paar Einstellungen im Framework vollkommen zu frieden, was das Responisive- Design betrifft.


    Nun kommt es natürlich drauf an, welche Basis Du (Joomlaversion, PHP, VirtueMart, Template) nutzt?

    Nun wäre noch die Frage, von welcher Version auf welche upgedatet wurde?


    Auf jeden Fall gibt es in der Kofiguration vom VM eine Einstellung, durch welche bei nichtvorhnden einer Sprache automatisch die Englische gezogen werden soll.


    Es kann auch helfen, die deutschen Sprachdateien händisch in die Ordner:


    /administartor/components/com_virtuemart/language/de-DE

    und

    /components/com_virtuemart/language/de-DE


    zu kopieren.


    Das Verzeichnis "/administrator/components/com_virtuemart/helpers/vmlanguage.php" ist nicht das Verzeichnis, aus dem die Sprchdateien für den VM Betrieb gezogen werden.

    Hallo Alexaner,


    ich bin mir jetzt nicht ganz sicher, aber ich denke ab Werk steht diese Einstellung auf "none", sodaß sich kein neues Fenster öffnen sollte.

    Eventuell kannst Du mal in deinen Override- Ordner reinschauen, ob diesbezüglich was geändert wurde?


    Falls ja, einfach mal kurz per "_" deaktivieren und schauen ob sich was ändert.

    Hallo Markus,


    willkommen im Forum. Handelt es sich um eine Neuinstallation oder hat der Shop vorher funktioniert? Was wurde geändert?


    Welche:

    Joomla Version?

    VirtueMart Version?

    PHP Version?

    Welches Template?

    Hast Du die aktuelle VM Sprachversion installiert?

    Das war der Grund für mich, auf VP_Merchant von VirtuePlanet umzusteigen.

    Hallo SirBoerky,


    magst Du mir verraten, wie Du das bei Dir mit dem Copyright Hinweis unten Links in deinem Footer hinbekommen hast? Ich habe bereits alle Module sowie die Merchant Konfiguration durchgesehen, jedoch keine Lösung gefunden. Eventuell sehe ich ja auch den Wald vor lauter Bäumen nicht?


    Danke schon mal

    der Faro

    Okay, dass VM immer noch nicht zu 100% Php 8 kompatibel ist ist nicht so toll, kann ich aber erstmal mit leben.

    Hallo Michael,


    ich betreibe VM sehr gut mit PHP 8. Jedoch noch unter J 3.10.11

    Auch ich habe eine J 4 Testinstallation bei welcher ich zur Zeit auch nicht weiter als bis zur Adresseingabe komme. Bei mir ist es die Fehlermeldung (Tooltips kann nicht geladen werden). Eventuell ist es nur ein Templatefehler vom Cassiopeia, welches ich zum Testen nutze. Kann sein, dass dieser Fehler unter meinem neuen VP_Merchant nicht auftritt. Das muss ich erst noch Testen.


    So wie der Stefan es schon sagte, J 4 ist noch nicht stabil genug um es produktiv einzusetzen. Ich selbst werde mich was diese Migration betrifft an kalte Winterabende so im November, Dezember rantasten.


    Bis dahin ist man mit VM 4.0.6 und J 3.10.11 am besten beraten. Welches Template für J 4 nutzt Du?

    Evtl. liegt es daran, weil Du "Layout Bootstrap Version" auf bs3 eingestellt hast, da würde ich auch auf "Keine" gehen. Möglicherweise wird mit bs3 das CSS trotzdem geladen.

    Hallo Stefan,

    danke, das war der richtige Hinweis. Jetzt sieht es viel schicker aus. Wie es scheint, braucht es gar nicht die Vorgaben der VM Konfiguration sondern nur die Bootstrap Version des Frameworks?


    Beste Grüße

    der Faro :)

    Hallo Stefan,


    ich versuche mich gerade in die Konfiguration des Merchant reinzudenken. Bei meinem damaligen Framework gab es eine Config in welcher alles gespeichert wurde. Diese wurde bei einem Update nicht überschrieben.


    Im Merchant wird nun alles anders gehandhabt. da muss man in PHP und CSS schon sehr fitt sein.

    Weil ich es nicht besser wusste, habe ich bisher alle Änderungen in der default.css und default.less durchgeführt. Und auch nur diese beiden Dateien wurden verändert. (Ich weiß, dass diese Dateien bei einem Update überschrieben werden).


    Kann ich nicht einfach diese beiden Dateien kopieren und sie in custom.css und custom.less umbenennen, um sie dann in den custom Ordner zu legen. Sind den in diesen beiden Dateien alle Einstellungen erhalten?

    Leider stehe ich ich mit der Dokumentation auf der VP Seite vollkomen auf dem Schlauch, weil ich einfach das Routing im Merchant nicht vertstehe.


    Das dauert bei mir noch einige Monde :)

    Beste Grüße

    der Faro

    Ich habe gerade keine Testinstallation mit dem Merchant auf dem Server. Ich könnte das im Laufe der Woche einmal installieren.

    Das würde mich sehr freuen Stefan, vielleicht kannst Du es auch reproduzieren, dass trotz deaktivierten "User Login Modul" dieses "vpf-modal-login-form" geladen wird. Ich denke der Befehl kommt irgendwo von Framework.


    ich danke Dir schon mal und beste Grüße

    der Faro:)

    Hallo Stefan,

    vielen Dank für deine schnelle Antwort. Ich kann leider kein anderes Modul als das User Login von Joomla finden. Hat das Template ein zusätzliches mitgebracht? Ich habe leider kein zusätzliches gefunden.


    Edit: habe gerade mal geschaut, da wird irgenwo eine "vpf-modal-login-form" geladen, kennst Du sowas?


    Du kannst gern auf meiner Mainseite nachschauen, ich habe das Merchant bereits Online :)


    Danke der Faro

    Hallo Stefan, hallo Forum,


    nun bin ich glücklicher Besitzer des VP_Merchant, daher möchte ich die folgende Frage bitte gern an Dich persönlich richten, da Du ja der VP Spezialist bist. :) Natürlich kann mir auch jeder andere weiterhelfen!


    Ich habe das Frontend Login Modul komplett deaktiviert und auch so eingestellt, dass es auf keinen Seiten zu sehen sein soll. Dennoch wird es mir (nur) im Quelltext auf jeder Seite angezeigt.

    Gibt es in der Merchant Konfiguration igendwo einen Reiter, den ich bisher übersehen habe und mit welchem ich dieses Login Modul auch für den Quelltext deaktivieren kann?


    Danke schon mal

    der Faro ;)

    Hat schon jemand getestet, ob mit der vm 4.0.7.x vom 6. Sept. das Problem schon behoben ist?

    Versionen mit ungeraden Zahlen haben immer den Entwicklerstatus und sollten noch nicht oder mit besonderer Vorsicht produktiv eingesetzt werden.

    Generell ist immer zu raten, neben seinem Liveshop eine Testspiegelung inkl. eigener Datenbank zu betreiben. Somit ist man auch selbst schnell in der Lage, neuerungen zu Testen.


    Sollte damit dann das Problem behoben sein, und es keine anderen Probleme mit sich bringt, kann man auch diese Version in seiner produktiven Umgebung installieren.

    Hallo in die Runde,


    genauer gesagt, geht die Frage eher direkt an den Stefan, da er ja hier im Forum wie ich denke, der VirtuePlanet Profi ist. ;)


    Ich bin gerade dabei mich in das VP Template Merchant zu verlieben. Bevor ich mich dort registriere und auf den Kaufen- Button drücke, habe ich bitte noch ein paar Fragen.


    1. Da es das Template nur auf Englisch gibt, werden die Deutschen VM Sprachdateien z.B im Warenkorb (In den Warenkorb) angewand, oder bleibt es bei (Add to Card)?

    2. Muss ich das VP Minicard Module für den Warenkorb anpassen, oder reicht es aus, das VM Cartmodul lediglich auf die Modulposition Minicard zu setzen?

    3. Da ich nur eine Lizenz benötige, kann ich es zusätzlich auf meiner Demoseite zum Testen installieren?

    4. Ist VirtuePlanet Zukunftssicher? Meine Bedenken gehen ich die Richtung, da viele gute Produkte von Konkurrenzunternehmen geschluckt werden um sie dann Platt zu machen.


    Danke schon mal im Voraus.

    Hallo Sabine,


    auch ich bin auf der Suche nach einem pasenden Template für Joomla 3 und 4 und schaue mich gerade ebenfalls dort um.

    Wie es scheint, gibt es das "VP Framework" tatsächlich nur in Englisch. Auch das Forum scheint nur in Englisch zu sein. Schade!


    Wobei ich persönlich mit Englisch kein Problem habe. Ich könnte mich mit meinen wenigen kenntnissen schon irgendwie durchmogeln.


    ABER, ich würde mich über eine Demoversion freuen, in welcher ich erst einmal schaue, wie ich mit diesem Framework zurecht komme. Der Kaufpreis für eine Lizensierte Version wäre für mich OK.

    Hallo Klaus,


    Das Horme 3 findest Du Hier. Dann Die 4.0.4_package runterladen und aus dieser nur das Horme 2.0.0 installieren.


    Zu deinem "www run" Problem wäre es besser, ein neues Thema zu eröffnen, damit dieses Thema hier nicht den Ramen sprengt.