Joomla + VM + SSL Vorgehensweise

  • Hallo zusammen,
    bin ein Anfänger was VM und auch SSL angeht. Mir ist klar, dass man ein SSL Zertifikat erwerben und installieren muss. Nun habe ich aber ein anderes Problem bzw. Frage. Da ich nicht meine komplette Seite: http://www.meineseite.de auf SSL umstellen möchte, sondern eben nur den VM Shop bzw. wenn es ums bezahlen geht. (Aktivieren Sie SSL für sensible Bereiche ). Jetzt ist aber meine Frage wie das funktioniert. Da ich ein Zertifikat ja nur auf eine Seite bzw. Link machen kann. Entweder https://www.meineseite.de oder https://shop.meineseite.de.
    Jetzt aber meine Frage. Wie bekomme ich es hin, dass VM auf einer subdomain ( shop.usw.) läuft. Oder wie geht man hier vor ? Komme einfach nicht weiter und möchte nichts falsch machen. Kann mir hier jemand weiter helfen oder gibts vl eine Anleitung wie vorzugehen ist ? Danke vorab


    Christian

  • I`m not a perfect person. I make a lot of mistakes....
    :o But still, I love those people who stay with me after knowing how I really am. :o


    Problem gelöst? Dann bitte auch die Lösung posten und Beitrag auf [gelöst] setzen.


    Im aufgerufenen Thema siehst Du oben den Satz "Dieses Thema als [GELÖST] markieren.
    Nach Anklicken wird das Thema auf gelöst gesetzt und der Satz verschwindet.

  • Hallo Gemeinde,


    da ich mich gerade mit diesem Thema beschäftige, habe diese alte Leiche wieder ausgebuddelt.


    Ich wollte fragen, ob jemand diese Geschichte schon einmal durchgeführt hat? Genau gesagt, einen funktionierenden VM-Shop von http zu https umstellen. (Gesamte Joomlaseite)


    Und worauf ich genau achten muss? Die links in den beiden vorangegangenen Themen sind ja schon etwas älter.


    Ich habe ein SSL- Zertifikat erworben. Habe es aber meiner Domain noch nicht zugeordnet. Mit der "301 Weiterleitung" per htaccess habe ich mich auch schon beschäftigt.


    1. Muss ich mit den sicheren Pfaden was beachten, über welche meine Downloads und Rechnungen funktionieren? Oder werden diese automatisch mit umgeleitet?


    2. Muss ich zusätzlich "ssl für sensible Bereiche" aktivieren?


    3. Was muss ich bei meinen Bezahlmodulen w.z.b. PayPal, Sofort, Amazon und Vorkasse beachten?


    Ich habe leider zu diesem Thema im Netzt nicht wirklich was auf Deutsch gefunden, wo die Herangehensweise Schritt für Schritt erklärt wird.


    Mein System:


    Joomla: 3.6.2
    VirtueMart: 3.0.18
    PHP: 5.6


    Vielen Dank schon mal
    Faro

  • Hallo Faro,


    es ist kaum etwas zu beachten, wenn Du die gesamte Seite auf SSL laufen lässt, schlimmer wird es nur, wenn es nur teilweise aktiviert ist, was meiner Meinung nach kaum Sinn macht.


    In Joomla kannst Du "Erzwinge SSL" einschalten, bzw. ist es schneller, wenn Du in der .htaccess eine zwingende Umleitung auf https hast.


    Damit bist Du im Grunde durch, "SSL für sensible Bereiche" nicht einschalten.


    Die Zahlungsarten sollten normal weiterlaufen, mit Paypal habe ich in meinem Shop keine Probleme. Neu ausgestellte Zertifikate sollten auch den Vorstellungen von Paypal genügen.


    Auf die Schnelle
    Stefan

  • Hallo Stefan,


    der Meinung war ich auch, dass nur eine komplette Umstellung der Seite auf "https" Sinn macht. Da ja auch Google wenn auch noch nicht so wichtige Rankingvorteile gegenüber einer "http" Seite verspricht.


    Dann werde ich mich mal in kalten Tagen bei machen, und die Umstellung vornehmen. Ein paar Informationen muss ich auch noch einholen, was andere bestehende Extension auf meiner Seite betreffen.


    Edit: @Stefan, was meinst Du genau mit: "In Joomla kannst Du "Erzwinge SSL" einschalten, bzw. ist es schneller, wenn Du in der .htaccess eine zwingende Umleitung auf https hast"?


    Ist beides nicht das gleiche?


    Danke und beste Grüße
    Faro

  • Völlig richtig.
    Für die Bezahlarten braucht man garkein SSL! weil alles sensible über die Provider geht. Abgesehen davon, was man kauft. Um das abzufangen braucht man eh SSL für die ganze Seite (für die ganz Paranoiden).


    Aber halt auch, wegen Google. Das heißt die Option "nur für sensible Bereiche" sollte ich eigentlich löschen. Denn sie vermittelt nur eine falsche Vorstellung. Es war mal sinnvoll. Als server auch deutlich langsamer durch SSL wurden, aber das ist heutzutage wirklich Peanuts. Manche sagen es geht sogar mit SSL teils schneller (durch seltsame Effekte).


    Letztendlich um die Frage von hatschipu zu beantworten, wie macht man das jetzt? Ich empfehle ein Multidomain Zertifikat, was in seinem Fall für *.meinseite.de ausgestellt wäre. Wir haben so ein Zertifikat für https://virtuemart.net/ und man beachte das Zertifikat hier https://extensions.virtuemart.net/


    Es lohnt sich, gibt imho sogar besseres Ranking,.. munkelt man, obs stimmt weiß ich nicht. Wir hams eh gebraucht.

  • Hallo Milbo, hallo Stefan,


    vielen Dank für eure Tipps. Ich habe nun erfolgreich auf "https" umgestellt. Tetbestellungen funktionieren auch. Nur bekomme ich manchmal und auch nur im Firefox, diese Fehlermeldung.



    Im IE oder Opera funktioniert alles Bestens. Ich habe in der Conf. "https erzwingen", "ganze Seite" aktiviert. Muss ich auch noch zusätzlich in der .htaccess diese Eintragung vornehmen?
    -----------------------------------------------------
    RewriteEngine On
    RewriteCond %{SERVER_PORT} !^443$
    RewriteRule (.*) https://%{HTTP_HOST}/$1 [R=301,L]
    -----------------------------------------------------
    Und ich habe bei "joomlart" gelesen, dass auch in der Joomla conf. dieses eingetragen werden soll?
    -----------------------------------------------
    Find the following line:


    var $live_site ='';


    Replace with:


    var $live_site = 'https://www.your-domain.com';
    -----------------------------------------------


    Danke für eure Hilfe. Beste Grüße
    Faro

  • Servus Faro,


    das var $live_site steht in meiner Konfiguration auch auf https...


    Die Fehlermeldung im Firefox kenne ich so nicht, kann es evtl. sein, dass noch irgendwelche Bilder oder ähnliches von einem anderen Server ohne https geladen werden?


    Grüße
    Stefan

  • Hallo Stefan,


    du meinst "https" mit "www" und der url zu deiner Startseite? Ich habe zwischendurch leider noch nicht rausbekommen, wuzu diese Eintragung nötig ist. Hast Du da eine Idee? Ist das dann nicht eine generelle Umleitung zur Startseite?


    Zu meiner Fehlermeldung:


    Es ist schon eigenartig. Externe Bilder werden nicht mehr geladen (Mixed Content über http). Das habe ich überprüft. Ich bekomme diese Fehlermeldung auch im Backend wenn ich z.b. auf Konfiguration klicke. Aber auch nicht mit jedem Firefox. Auf meinem Laptop zu Hause habe ich das Problem nicht. Caches habe ich geleert.


    Danke und beste Grüße
    Faro

  • Servus Faro,


    ich hab in der Vergangenheit ein paar Mal nach der Bedeutung gesucht, aber selbst in den Joomla Docs habe ich nur schwammige Aussagen dazu gefunden.


    Meine Domain wird per .htaccess auf www umgeleitet, die Angabe in der configuration.php in meinem Fall ist:
    public $live_site = 'https://www.jooglies.com';


    Kann auch sein, dass die Angabe durch "Erzwinge SSL" eingetragen wird, hab ich noch nicht überprüft. Wenn ich eh gerade teste, mach ich das demnächst einmal, aber ehrlich gesagt, läuft es so bei mir, und ich hab bisher noch keine Energie hineingesteckt, das bis aufs Kleinste zu durchleuchten. Den Quellcode da abzusuchen ist fast noch zu schade für regnerische Wintertage. ;-)


    STS

  • Hallo Stefan,


    habe nun auch meine https Seite in die "$live_site" eingetragen. Ich habe aber auch wie Du, keinerlei Änderungen feststellen können.


    Ich werde morgen mal zum Testen meinen Laptop, auf welchem mein Firefox funktioniert, mit ins Büro nehmen. Eventuell liegt es ja auch am Router, welcher mit diesen neuen "IPv6" Adresen arbeitet. Eventuell gibt es ja mit diesen Probleme.


    Danke und Beste Grüße
    Faro

  • Durch den Post angeregt, habe ich mich erneut damit beschäftigt.


    Also in allen Versionen unter vm3.0.18.1 muß man das SSL auf Joomla UND Vm aktivieren! und das mit den sensiblen Bereichen, wie gesagt, würde ich lassen, da es wie Faro bereits bemerkte ganz schnell zu "gemischten" Inhalten führt.


    Noch viel schlimmer ist eigentlich das Session problem. SSL kann so eingestellt sein, daß man letztendlich eine neue Session erhält. So hätte man dann in den sensiblen Bereichen Produkte im Warenkorb und ansonsten nicht.

  • Hallo in die Runde,


    ich habe doch noch ein Problem mit "https".


    Wird ein Artikel in den Warenkorb gelegt, aktualisiert sich dieser auch im Hintergrund. Wenn ich dann auf "Warenkorb anzeigen" klicke, ist dieser leer.


    Erst nachdem ich eine Adresse eingebe, und auf "Weiter einkaufen" klicke, dann einen Artikel in den Warenkorb lege, wird der Artikel auch angezeigt.


    Habe ich noch irgendeine Funktion vergessen anzucklicken nach meiner Umstellung auf "https"?


    In meiner Shopspiegelung, welche noch unter "http" arbeitet, funktioniert alles wie gewohnt bestens. Also muss es ja was mit dem https Protokoll zu Tun haben.


    Danke und beste Grüße
    Faro

  • Knapp 3 Stunden und eine Kaffeekanne später habe ich festgestellt, dass das Sessionproblem (https) im Büro nur mit meinem "IPv6" Router der DT aufrat.


    Im Backend z.b. ging gar nichts. Produkte oder Bestellungen bearbeiten? Keine Chance. Der Browser bricht mit der Fehlermeldung "Gesicherte Verbindung fehlgeschlagen" ab.


    Zu Hause mit minem Vodafone- Router, welcher mit den Standard IP-Adressen arbeitet, habe ich das Sessionproblem nicht. Produkte bestellen und Bestellungen bearbeiten kein Problem.


    P.S. Joomla Update auf 3.6.4 unter "https" mit "IPv6", keine Chance! Joomla Update auf 3.6.4 unter "https" mit Vodafone- Router, keine Probleme!


    Testumgebung:
    Firefox (Aktuelle Version)
    Joomla: 3.6.4
    VM: 3.0.18
    PHP 5.6.26


    Beste Grüße
    Faro

  • Einige Stunden später, jedoch ohne Kaffee weil, (ich kann nicht mehr);) muss ich leider alles wieder auf 0 setzen.
    Ich habe nun bei meinen Browsern den Cash geleert und, egal ob Ipv6 oder nicht, der Warenkorb bleibt leer. Nur wenn ich erst die Adresse eingebe, funktioniert es.


    Ich möchte auch nochmal betonen, dass ich kein Softwareentwickler und auch kein Programmierer bin. All mein Wissen über Joomla und VM habe ich mir aus Foren und Selbsttests auf meiner VM Testpage erarbeitet.
    Daher möchte ich nun doch nochmal einen Hilferuf aussenden.


    Ich hatte mir die Umstellung auf „https/SSL“ meines Shop's einfacher vorgestellt.


    Wenn ich nun das sogenannte „Session Problem“ Google, falle ich wieder auf Probleme aus 2014/15 zurück.
    Dazu habe ich mir mal den Shop von „Media Service Essen“ angesehen. Dort funktioniert alles bestens mit Firefox und IE.


    Ist es ein Problem von Joomla, VM oder ein Browserproblem? Ich finde im Netzt keine konkreten Ansätze, woran es nun genau liegt. Ich habe nur gesehen, dass es bei „Media Service Essen“ klappt.


    Wenn ich mein iPhone nehme, dem ist es egal welches W-Lan oder Hotspot. Da kann ich nach belieben Bestellen. Oder kann man im iPhone auch den Cash leeren? Bitte enttäuscht mich und sagt JA!:mad:


    Es geht ja nicht nur um das sogenannte „Session Problem“. Momentan funktionieren bei mir auch nur die Bezahlarten „Vorkasse“ und „PayPal“. „Sofort Überweisung“ und „Amazon Paymentes“ haben momentan ebenfalls ihren Dienst in meinem Shop eingestellt, und zeigen es mir mit einer Fehlermeldung im Ordner „logs“ an.


    Ich wäre über jeden Hinweis Dankbar wie ich es schaffe, Joomla, VirtueMart und SSL in Einklang zu bringen. Oder sollte es wirlich nur den einen Weg geben, zurück zu „http“?


    Edit: Habe nun bei meinem Hoster nachgesehen. Ich habe ein Single Domain Zertifikat für die gesamte Domain erworben und dieser zugeteilt. Ist das das Problem für das "Session Problem"?
    Brauche ich ein anderes, bei welchem das Session Problem nicht vorkommt?


    Ich dachte immer, es sei einfacher die ganze HP / Domain zu ssl zu machen als nur Unterseiten.
    Ich hätte nie gedacht, dass es da Unterschiede gibt. Oder doch nicht?


    Durch den Post angeregt, habe ich mich erneut damit beschäftigt.


    Also in allen Versionen unter vm3.0.18.1 muß man das SSL auf Joomla UND Vm aktivieren! und das mit den sensiblen Bereichen, wie gesagt, würde ich lassen, da es wie Faro bereits bemerkte ganz schnell zu "gemischten" Inhalten führt.


    Noch viel schlimmer ist eigentlich das Session problem. SSL kann so eingestellt sein, daß man letztendlich eine neue Session erhält. So hätte man dann in den sensiblen Bereichen Produkte im Warenkorb und ansonsten nicht.


    Wo genau muss ich in VM, SSL aktivieren? Ich kann in der VM Cofig dazu keinen Kasten mit Häckchen finden?


    Joomla: 3.6.4
    VM: 3.0.18
    PHP 5.6.26


    Danke schon mal und beste Grüße
    Faro

  • Faro, ich habe es selbst so gemacht:
    - Rapid SSL Zertifikat von meinem Hoster, ca. 2 Euro mtl.
    - Bei Virtuemart KEINE Einstellungen verändert
    - Bei Joomla Front- und Backend SSL erzwingen
    - in der .htaccess umleitung auf ssl wie folgt:


    Code
    1. ##########################################################
    2. ## Umleitung http zu https ###############################
    3. RewriteCond %{SERVER_PORT} !^443
    4. RewriteRule ^(.*)$ https://shop.virtuemart.de/$1 [r=301,L]
    5. ##########################################################


    Dazu noch als Ergänzung: Da ich das auf der Subdomain habe, gibt es bei mir keine Umleitung von non-www nach www.

  • Hallo Michael,


    danke für deine Erklärung. Ich muss jetzt leider zum Termin. Ich werde es gleich morgen Vormittag testen.


    P.S. Mit meinem "Single Domain Zertifikat" geht das bestimmt nich oder? Muss auch erstmal nachlesen, wo der Unterschied zu einem "Rapid SSL Zertifikat" ist.


    Danke und beste Grüße
    Faro