Amazon Pay Fehlermeldung

  • Hallo,
    habe in einem neuen Shop, Joomla 3.8.13, aktuellster VM im Setup neue Zahlung Amazon Pay ausgewählt. Nach dem Speichern ist die Seite im Frontwnd weiß - mit folgender Fehlermeldung:


    Warning: require_once(OffAmazonPaymentsService/MerchantValuesBuilder.php): failed to open stream: No such file or directory in //plugins/vmpayment/amazon/library/OffAmazonPaymentsService/Client.php on line 23


    Wenn ich in der betreffenden Datei in der Zeile auskommentiere, ist die Seite ersmtal wieder da.
    Ich bin natürlich überrascht und finde es schweierig, wenn eine im System vorhandene Zahlungsart schon ab Werk solch ein Problem verursacht.


    Daher meine Frage in die Runde, wem das Problem bekannt ist - was zu tun ist, um Amazon payp anwenden zu können?
    Von Amazon ist da sicher kein Support zu erwarten - dort verweist man auf Virtuemart ...


    Danke daher für jeden Hinweis dazu.
    MfG FDE

  • Ich bin natürlich überrascht und finde es schweierig, wenn eine im System vorhandene Zahlungsart schon ab Werk solch ein Problem verursacht.


    Hallo,


    von Haus aus funktioniert es ohne Probleme. Zumindest hat meine Amazon-Payment Einrichtung bestens funktioniert. Ich bin mir nicht sicher, ob ich letztendliche Helfen kann, aber wichtig wäre zb., welche VM-Version nutzt Du, welche PHP-Version ist bei dir Aktiv? Auch Joomla kann auf die Version 3.9.1 gehoben werden.


    Was ich jedoch aus der Fehlermeldung erlesen kann ist, dass dem Plugin noch Händlerangaben aus dem Amazon-Konto fehlen. Es müssten meiner Meinung nach Informationen aus dem "Amazon-Sellercentral" sein.


    Von Amazon ist da sicher kein Support zu erwarten - dort verweist man auf Virtuemart ...


    Kann ich nicht bestätigen, Der Amazonservice ist das Beste, was ich jemals an Services kennen gelernt habe. Nach Anfrage per Mail über meinen Amazonhändleraccount bekommt man umgehend eine Antwort. Und, Amazon hat mir damals bei der Einrichtung als VM mit Amazon noch in den Kinderschuhen steckte, am Telefon bei der Einrichtung geholfen.



    Gruß Faro

  • Hallo Faro,


    vielen Dank für die schnelle Meldung.
    Ja wie gesagt, VM ist die letzte Version, Joomla habe ich noch geupdated, da es bei anderen Seiten Probleme gab ... aber das muss dann auch mal gemacht werden.
    Tatsächlich sind die Sellerdaten da noch nicht eingetragen - dann bearbeite ich das erst weiter, wenn das Sellerkonto vollständig eingerichtet ist. Ich hätte nur nicht erwartet, dass die unvollständige konfiguration schon dazu führt, dass bei Aufruf des Warenkobs (zuletzt nach nochmaliger Einrichtung war die Seite dann OK, aber sobald man den Warenkorb aufrief, kam die Fehlermeldung) die Meltung kommt ...
    Dann gebe ich Rückmeldung, wenn das geklärt ist.


    Dankeschön
    MFG FDE

  • Hallo FDE,


    ja in der Tat, der Händleraccount "Cellercentral" muss vollständig abgearbeitet sein. Mit allen Registrierungen und Akreditierungen hat es bei mir damals auch gut zwei Wochen gedauert. Wenn dann alles erledigt ist, muss Du dein Händlerkonto nur noch "Aktiv" schalten und danach das VM-Plugin befüllen. Dann sollte wie auch bei mir, alles problemlos funktionieren.


    Amazon ist was das betrifft, sehr genau. Schließlich jedoch sollen deine Produkte problemlos und sicher durch Die Welt gehen. :)

  • Hallo und guten Abend,

    nachdem nun alles bei Amazon aktiv ist, habe ich die vollständige Konfiguration noch mal durchgearbeitet und auch die Daten, Secret u.s.w. eingetragen (was schon vorher so war ...)

    Leider ist der Fehler unverändert!


    Unter den Plugins gibt es deren zwei (>Erweiterungen >Verwalten ...)
    Eines Spalte Verzeichnis System und eines VMPayment.
    Beide V 3.4.2


    Gibt es von der Schnittstelle (intern in VM) eine neuere Version?


    Mir ist unklar, warum gleich eine konkrete Fehlermeldung erscheint - denn das VM-Payment-Plugin ist deaktiv. Aktiviere ich es, ist weder das Front noch das backend zugerifbar. Es erscheint sofort der Whitescreen mit Fehlermeldung!


    Das Bedeutet ja eher, dass intern schon im Syste etwas falsch läuft - das hat, so würde ich vermuten, mit Amazon noch gar nichts zu tun ...


    Danke daher für jeden Hinweis / Tipp

    MfG

    FDE

  • Um der Community auch was zurück zu geben, hier ein Lösungsansatz, den ich über das englischsprachige Forum erhalten habe.


    I found a file here https://github.com/amzn/amazon…MerchantValuesBuilder.php

    Perhaps if you copy missing files from lib/ folder to the plugins/vmpayment/amazon/library/ it solve your problem.


    Im Endeffekt fehlen in der in VM enthaltenen Schnittstelle diverse Libraries.
    Aktuell scheint es zu funktionieren - jedoch in sehr kurioser Art der Ausgabe.

    Der Amazon Button ist oberhalb des Warenkorbes ... während unten, unterhalb der Versandart, die Checkbox mit der schon installierten Paypal Auswahl erscheint.
    So lässt sich das nicht nutzen - werde aber einen neuen threat dafür öffnen, da das anderer Inhalt ist.

    Danke


  • Wenn ich das Amazon Plugin aktiviere, dann muss ich es über die DB wieder abschalten, da ich danach nicht mehr in mein Backend komme.

    Ich habe als Plugin installiert:


    VM Payment - Pay with Amazon (Das macht die Probleme, sobald es aktiviert wird.

    System - Pay with Amazon (Ist schon immer aktiviert, hier passiert nichts.

    VM Version ist die 3.4.5 10035


  • In der AIO-Komponente sind alle Plugins, ich würde aber nicht empfehlen, Plugins mit unterschiedlichen Core-Versionen zu mischen. Wenn Core-Funktionen geändert werden und die Plugins angepasst werden müssen, passiert das normalerweise in einem Schritt. Unterschiedliche Versionen können, müssen nicht, die Funktionalität ändern oder zerstören.

  • So bin mal wieder an Amazon Pay

    Habe auch alles geupdatet. Im Sandbox-Modus erhalte ich nun folgende Meldung




    Ich logge mich mit meinem Testkonto ein (deutsche Lieferadresse) nur leider erhalte ich dann diese Meldung nach dem einloggen.

    Habt ihr eine Ideee was das für ein Fehler sein könnte?

  • In der AIO-Komponente sind alle Plugins, ich würde aber nicht empfehlen, Plugins mit unterschiedlichen Core-Versionen zu mischen. Wenn Core-Funktionen geändert werden und die Plugins angepasst werden müssen, passiert das normalerweise in einem Schritt. Unterschiedliche Versionen können, müssen nicht, die Funktionalität ändern oder zerstören.

    Das war seit vm3.0.x stable. Nur jetzt hat sich etwas geändert. Bitte hier weiterlesen http://forum.virtuemart.net/in…43386.msg506745#msg506745
    Amazon durfte ich leidern nicht updaten.