Anleitung zum Upgrade von 3 auf

  • Moin miteinand,

    mittlerweile stehen ja viele vor der Frage eines Upgrades. Was ich – und aus Gesprächen ahnend nicht nur ich – vermisse ist eine Reihenfolge:

    Was zuerst?
    Template – wenn es nicht unter Joomla 4 läuft?
    Joomla 4?

    Plugins?
    VM 4?

    Und die Reihenfolge bei VM?

    ’s Grüßle

  • Moin,

    das ist gaz einfach, und wurde auch hier im Forum des öfteren besprochen. VM läuft in der Version 4.0.6 auf J3 und J4. Welche Plugins meinst Du genau? Die Plugins von VM werden automatisch in der aio 4.0.4 mit aktualisiert.

    Das Template sollte natürlich für VM 4 und Joomla 4 geeignet sein.


    Die wichtigste Frage wäre jedoch, welche Joomla, VirtueMart und Template Version nutzt Du zur Zeit?

  • Ich würde folgendermaßen vorgehen:


    das komplette System VM und Joomla in einem Unterordner Spiegeln inkl. eigener DB.

    Dann würde ich unter J 3.10.10 VM auf die Version 4.0.6 bringen. Müsste eigentlich im Backend angezeigt werden: com_4.0.6 und aio_4.0.4


    Nun weiß ich nicht, welche anderen Erweiterungen Du noch nutzt. Diese müssen ebenfalls J4 kompatibel sein. Sollte dann alles ok sein, kannst Du auf J4 Upgraden. Aber wie gesagt, erst nur in der Testumgebung und vorher bitte eine Datensicherung inkl. DB vom alten System machen, dann bist Du auf der sicheren Seite falls was schief läuft.


    Was Dein Template betrifft, da wirst Du dir wohl eventuell ein neues suchen müssen, denn so wie ich es gesehen habe, ist deins bei Yoo nicht nehr erhältlich. Es kann auch sein, dass ich mich verlesen habe. Das kannst Du doch aber über deinen Yoo- Account in Erfahrung bringen.


    Soweit erst einmal in Kürze.

  • Servus,


    vorweg, ich rate dringend davon ab, VirtueMart Live-Shops jetzt schon auf Joomla 4 zu aktualisieren.

    Die Umstellungen in VirtueMart waren gravierend und es gibt immer noch Bugs, die erst im Laufe der Zeit bekannt wurden/werden.

    Joomla 4 unterläuft auch noch vielen Änderungen, da funktioniert manchmal nach einem Update etwas ganz anders als vorher.

    Anfang 2023 wird das evtl. entspannter sein, dann kann man die Situation neu überdenken.


    Natürlich ist der vorzeitige Test in einer Testumgebung sehr hilfreich, um eine Umstellung später zügig zu erledigen.


    Zum Update-Verlauf.

    (Hier sind andere externe Erweiterungen nicht mit berücksichtigt und es kann auch je nach Template unterschiedlich sein.)


    Meine voraussichtliche Vorgehensweise bei Shops mit VirtuePlanet-Templates.


    1. Template aktualisieren.

    2. VirtueMart über das Gesamtpaket aktualisieren (das mit ...package_or_extract.zip am Ende).

    2. Alternativ: VirtueMart Core, VirtueMart AIO, TCPDF, vmadmin(-Template) aktualisieren.

    3. Auf Joomla 4 aktualisieren.


    Das wird in einigen Fällen ein einfaches Abklicken der einzelnen Updates sein, in einigen Fällen auch ein schwieriges Unterfangen. Das hängt ganz davon ab, wieviele externe Erweiterungen vorhanden sind und welches Template benutzt wurde.


    Im Falle eines nicht kompatiblen Templates würde ich versuchen, eines zu finden, das sowohl unter Joomla 3 als auch unter Joomla 4 läuft.

    1. Dieses Template installieren.

    2. Darauf umschalten.

    3. Grob oder ganz einrichten.

    4. Das Update auf Joomla 4 machen.


    Eine Alternative wäre, auf Protostar zu schalten, dann das Joomla 4 Update zu machen, weil man dann auf dem Joomla 4 Standard-Template Cassiopeia landet.

    Von dort aus kann man dann entweder ein neues Template installieren oder das alte anpassen.


    Der Wege werden viele sein. Man muss den richtigen Weg für jedes individuelle System finden müssen.


    Grüße

    Stefan

  • Ich habe es direkt mal ausprobiert mit einem J3.10 Stand der Webseite auf dem VM noch nicht installiert war. Ich nutze XAMPP mit PHP 8.1.6.

    Virtuemart installiert mit dem DEMO-DAten --> läuft.

    Deutsches Sprachpaket installiert --> Fehler: Argument number specifier must be greater than zero and less than 2147483647


    Ich bin ratlos.

    Nachtrag: habe jetzt zu Testzwecken J3.10 blank installiert und virtuemart mit demodaten auf php8. Erst läufts - nach installation des deutschen Sprachpakets für vm tritt der Fehler wieder auf.


    Thema wird auch hier behandelt: Virtuemart 4 - Shop - Fehler: 0