Beiträge von Joerg

    Hallo community

    beim Layout des Warenkorbs habe ich ein Problem, dasim Anhang dargestellt ist.

    Wenn ich in den Rechenregeln die Regelbezeichnung "MwSt 19%" nenne, habe ich die doppelte Anzeige der Prozente im Warenkorb. Wenn ich jedoch nur MwSt eintrage ist alles ok, aber ich kann die verschiedenen MwSt Regeln nicht mehr unterscheiden, wenn sie in einem Menü augewählen kann..... Ich habe mehrere Regelnder Länder wegen und die kann ich dann nicht mehr unterscheiden.


    Kann ich das irgendwie ändern? Eventuell mit einem Override?

    Ich komme leider nicht weiter.


    Danke schon mal im voraus

    Joerg


    Moin Stefan,


    danke für die ausführliche Info.

    Ich nehme an das das PPPlus auch gleich mehr Kostennach sich ziehen wird, die Gebühren werden sicher nicht die selben sein als beim normalen PP.

    Fürs erste bleibe ich auch dabei, denn Kauf auf Rechnung biete ich nicht an und wirds auch nicht geben. Zumindest nicht im Shop.


    Danke

    Joerg.

    Hallo Stefan,


    ich bräuchte eine Info bezüglich PayPal. Ich denke Du weist das.

    1. Ich habe ja gesagt das ich z.Z. keine API's nutze. Hat es einen Vorteil diese zu verwenden? Bietet es irgendwelche Vorzüge, wenn ich die Abwicklung mit API's mache (hab das alles schon in der Sandbox eingerichtet und getestet und meines Erachtens hat das auch funktioniert. Ich bin mit der Einbindung des smart buttons nicht glücklich)

    2. PayPal hat mir jetzt das Plus angeboten. Hat das, außer das man auf Rechnung kaufen kann und mehrere Zahlmöglichkeiten einrichten kann, andere Vorzüge, die mir zugute kommen würden.

    Kauf auf Rechnung ist eigentlich gar nicht geplant, wie funktioniert das mit PayPal???

    Was mir prinzipiell nicht gefällt ist, wenn man beim Checkout erst verifiziert wird und man dann wieder zurück auf die site kommt und dann wieder zu PayPal. Mir ist es lieber ich tätige meinen Kauf und gehe mit meiner "Rechnung" an die Kasse.


    Danke & Gruß aus dem verregneten Deutschland ins warme Indien

    Joerg.

    Hallo Stefan,

    danke für die Info. Ich habe eine andere Vermutung, aber da wird er sich die Zähne (hoffe ich doch) ausbeißen.

    Er hat es geschaft das seine IP vom Security Tool gesperrt wurde, mit entsprechenden Angaben von Risiken. Dann hat er nachts x mal versucht was zu kaufen, bis wieder das Security Tool zugeschlagen hat.


    Ich habe eigentlich gedacht das PayPal nicht Standort abhängig ist, was Du mir ja bestätigst.

    Zudem gehen meine Verkäufe überwiegend ins EU-Ausland und da hat bis vorhin noch alles wunderbar funktioniert.


    Danke für die Info

    Joerg.

    Hallo community,


    hat jemand Erfahrung mit PayPal und Ausland? (EU) Macht das beim Bezahlen überhaupt einen Unterschied wo der Zahlungspflichtige gerade eingeloggt ist bzw woher er kommt?

    Problem: Käufer kommt aus Kroatien und der Kauf wird immer wieder abgebrochen, so stehts in der Bestellung, Kommunikation ist natürlich fast unmöglich, sodas ich nicht weis wo der Fehler liegen könnte. Ich kann ihm nicht entlocken wie weit er kommt oder was passiert.

    PayPal an sich funktioniert, was heist es haben Kunden aus Deutschland Bestellung und Bezahlung ganz normal abgewickelt und es hat alles. so wie gewollt, geklappt.

    Ich weiß auch nicht ob ich da was falsch mache. Zur Zeit läuft PayPal ohne API calls, also ganz normal. Das sollte doch kein Problem sein oder?


    joomla aktuell und virtuemart 3.8.6.10373


    Danke schon mal

    Joerg

    Ja kein Problem. Ich dachte das Problem ist nur für mich eins.


    Ich habe in der Custom.css das hier eingefügt

    Code
    1. .video-container { position: relative; padding-bottom: 56.25%; padding-top: 30px; height: 0; overflow: hidden; }
    2. .video-container iframe, .video-container object, .video-container embed { position: absolute; top: 0; left: 0; width: 100%; height: 100%; }

    dann habe ich ein Feld selbst erstellt in dem das hier steht


    Code
    1. <div class="video-container"></div>

    Wenn ich diese Feld meinem Produkt zu geordnet habe kann ich dort mein Video platzieren. und zwar so, ohne Größenangabe.


    Code
    1. <iframe src="https://www.youtube-nocookie.com/embed/pAL6sGxOWEs" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>

    zum Schluß sieht es dann so aus

    Code
    1. <div class="video-container"><iframe src="https://www.youtube-nocookie.com/embed/pAL6sGxOWEs" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>


    So mit kann ich die Videos in einem Tab unter dem Produkt ohne weiteren extensions/plugin darstellen.

    Ich dachte nicht das es helfen kann.

    Hallo community,


    erstmal ein frohes neues Jahr 2021.


    Wie im Titel schon geschrieben habe ich hierzu eine Frage.


    Wenn ein Gast die site besucht, ist erstmal für VM ja nicht ersichtlich woher der Besucher kommt, so sieht es für mich aus, denn es werden keine Versandmöglichkeiten angeboten.

    Ich habe zum Test die Versandoption "Brief" nur für Deutschland verwenden wollen. Wie gesagt bekommt der Gast erst nach dem eingeben der Lieferadresse diesen auch angezeigt, weil m.M. nach erst dann klar ist wohin die Reise geht.

    Jetzt habe ich im Hinterkopf das aber VM erkennen soll woher der Besucher kommt und das ist meine Frage. Erkennt VM die Herkunft des Besuchers? Und was müsste ich dazu tun.?

    Denn dann würde ja die für Deutschland geltende Versandmöglichkeit angezeigt werden.

    Wenn die Versandoption NICHT auf ein Land beschränke, bekommt der Gast diese angezeigt, dann müsste ich ja aber eine globale Möglichkeiten anlegen (also ohne Länderkennung) und eine weiter mit der Länderkennung und dem dann richtigen Preis usw.


    Kann das so sein?


    Nachtrag:
    VM 3.8.6 10373

    joomla 3.9.23

    habe zum Test den Geolocator installiert, leider hilft das nicht. Nach der Installation sagt er das ich aus Deutschland bin, also funktioniert er, aber der shop reagiert nicht.

    Habe es auch mit Käufergruppen versucht, geht auch, aber sobald ein Land dazu kommt erscheint keine Anzeige mehr.

    Hallo Joerg,


    Du kannst durchaus verschiedene Preise für die Gruppe Gast und die Gruppe Standard anlegen.

    Im Produkt legst Du dazu lediglich einen weiteren Preis an.

    Dem ersten Preis weist Du die Gruppe Gast zu, dem zweiten Preis die Gruppe Standard, Speichern, das war's schon.

    Ok verstanden, das heist, ich brauche gar keine separate Gruppe um registrierte User einen besseren Preis zu präsentieren, das ist doch was, muss ich gleich mal testen. Das würde mir schon reichen.

    Was mich dabei stutzig macht ist folgendes. Ich habe nur die beiden Gruppen, also default und guest.

    Sollte nach dem registrieren beim Käufer nicht automatische die entsprechende Gruppe nach dem registrieren angezeigt werden? Wenn ich bei Kunden gucke, haben sie keine Gruppe, weder default noch guest, aber die Zuordnung funktioniert. Das hilft mir enorm danke. Da kann ich mir die manuelle arbeit sparen. So wollte ich das.

    Ich habe schon in Deiner Signatur geschnüffelt, aber das war so für mich nicht ersichtlich. Danke. Ich komme darauf zurück.


    Gruß

    Joerg.

    Hallo Stefan,


    danke für die Info, ich weis bei dem vielen lesen gar nicht mehr so richtig wo ich bin, aber ok soweit habe ich das jetzt auch festgestellt.


    Und genau Dein beschriebenes Scenario wollte ich damit abdecken, Gast Käufer zahlen Preis x und registrierte Besucher sollten nach dem registrieren einer dafür angelegten Käufergruppe zugeordnet werden, um einen besseren Preis zu erhalten. Schade das das nicht geht, das wäre sehr interessant. Es ist bei mir so das sich Besucher registrieren sollen um den besseren Preis zu bekommen. Es wird aber nicht publiziert, wer also als Gast mit dem Preis zufrieden ist, wird erst nach dem registrieren merken das es billiger gegangen wäre. Ich möchte mir so eine gewisse zusätzliche Marge sichern.

    Nun gut, dann muss ich die Zuordnung, nach empfang der Benachrichtigung, über einen neuen User, manuell korrigieren.


    Andere Frage.

    Ich bin soweit mit meinem Shop fertig, mir fehlt jedoch das entsprechende Wissen um den "Rest" zu bewerkstelligen. Gibt es jemand, den Du kennst, der kleine kosmetischen Anpassungen als Dienstleistung anbietet? Es geht hauptsächlich um kosmetische Dinge, z.B. habe ich es ja geschaft, den Stock in der Detailansicht einzufügen, ist der Bestand aber Null, wird nichts angezeigt. Ich hätte dann dort gerne "nicht auf Lager" stehen gehabt, oder nach dem Login hätte ich gerne anstatt "Logout" dort den Usernamen stehen haben, eventuell mit dem Zusatz ausloggen, oder andersrum dem Befehl ausloggen den Usernamen voranstellen....oder die Versandmöglichkeiten beim Anklicken des links innerhalb des Shops dar zustellen mit einem modal, also einem eigenen kleinen Fenster oder im Content Bereich .... ich habe das schon in Beispielshops gesehen, finde es aber nicht mehr ....Solche Kleinigkeiten, nicht das ich nicht wollte es zu verstehen, aber ich kann es nicht. Ich habe da eine kleine Liste gemacht und bin natürlich auch bereit das entsprechend zu entlohnen. Für einen Profi eine Kleinigkeit, für mich der Flug zum Mars.


    Danke

    Joerg.

    Hallo community,

    ich finde auf folgende Frage keine Antwort, bzw verstehe ich was falsch.

    Vorweg angemerkt, habe ich das Gefühl das alles richtig läuft, was ich so sehe.


    Frage: Sollten Käufer nach der Registrierung im Shop nicht automatisch einer Käufergruppe zu geordnet werden?

    Falls ja, was könnte mein Problem sein das dies nicht stattfindet?


    Joomla: 3.9.23

    vm: 3.8.6 10373

    VP Template: 5.5


    BTW: Nach dem registrieren und dem verschicken des Bestätigungslinks, der auch ankommt, aber dann mit einem 403, Bestätigungscode konnte nicht gefunden werden, endet.

    Ich habe hier gelesen das dieses ein bekanntes Problem ist. Richtig? Ich habe die Option in der Config jetzt auf nein gesetzt und somit erhät der Benutzer keinen link und auch keine Fehlermeldung mehr.


    Danke.

    Hallo community,


    wo kann ich den Bereich zwischen Hersteller und Versandoptionen in der Produktansicht bearbeiten?

    Für mein Empfinden wären das Informationen die zum Shop gehören, wie Namen, Anschrift usw, , aber logischerweise finde ich da nichts.


    Wer kann mir diese Frage beantworten?




    Danke

    Joerg


    Dieser Bereich ist gemeint.


    Ich mach jetzt kein Nachtrag mehr, aber das ganze ist weiter führend. Hier was gezeigt wird wenn der Mindestbestand unteschritten wird.


    Es ist wie immer, nach langem suchen und testen hab ich es gelöst. Wieder einmal kannst Du löschen Stefan. Tut mir leid.

    Hallo Joerg,


    im Template gibt es einen Ordner layouts, dort sind alle Dateien, die VM beeinflussen.

    Danke, da werde ich mal auf die Suche gehen. Das ist zumindest ein Ansatz, weil eigentlich, für mein Verständniss, ist das doch das wirklich geringste Problem eine Variable an zu zeigen.


    Ich habe die Zeile gefunden, aber wo ganz anders, nämlich hier. In dem von Dir gesagten Dir war gar nix.


    templates\vp_merchant\layouts\default\html\com_virtuemart\productdetails.


    Und jetzt ist es da, ja der Bestand wird gezeigt.

    Wie bekomme ich jetzt noch den einen Text Lagerbestand: " davor?


    Noch ein Nachtrag,, habs soweit gefunden und auch hinbekommen, jetzt nur die Frage wie ich ein Leerzeichen zwischen Text und Bestand einfügen kann.


    In Stock50


    Vieleicht kannst Du mir da noch auf die Beine helfen Stefan.


    Danke

    Joerg.

    Hallo Joerg,


    man kann die Anzahl der vorhandenen Produkte in den Produktdetails so ausgeben:

    Code
    1. echo $this->product->product_in_stock;

    Das müsste in einen Override für das Produktlayout. Auf der VirtuePlanet-Seite ist dazu eine gute Dokumentation, allerdings auf Englisch.

    Hi Stefan, ich glaube ich habe das schon probiert, ohne Erfolg, sieh was ich als Antwort bekam.


    in the VP template I only see this

    <?php $show_stock = VmConfig::get('display_stock', 1); ?>
    <?php if($show_stock && $this->product->orderable) : ?>
    <div class="product-stock-cont col-sm-6">
    <?php $stock = VPFrameworkVM::getStockText($this->product); ?>
    <span class="<?php echo $stock->class ?> hasTooltip" title="<?php echo $stock->tip ?>"><?php echo $stock->text ?></span>
    </div>
    <?php endif; ?>

    so it will only show a text if in stock -- so u need to change the code if u want stk quantity to show


    Wo sollte ich das finden?, und was sollte als Syntax eingefügt werden,


    (ich weis schon einer Variablen eine Wert, wie auch immer der berechnet wird und diesen angegebener Stelle anzeigen, kannst aber nicht schreiben und/oder einfügen)

    Ich bin aber auch aufgrund der unterschiedlichen Aussagen verunsichert, es kann doch nicht das Problem sein, in acces wäre ich schon fertig. grrrr .... ich hasse es...


    Trotzdem Danke

    Joerg.

    Hallo community,

    diesmal löst sich das Problem nicht einfach durch posten, was schon mehrfach passiert ist 8)

    DIesmal brauche ich eure Hilfe.

    Folgende Installation:


    joomla 3.9.23
    vp merchant 5.5
    VirtueMart 3.8.6 10373


    1. Installation als offizielle site bei web.de

    2. Installation das Backup von 1 auch bei web.de aber andere URL (ich hatte die alle noch brach liegen und hab noch 2 bei 1und1, deswegen bei web.de)

    beide mit PHP 7.4.x

    3. Installation zu Hause auf einer DiskSttation.

    alte PHP Version


    aus dem quick_start_vp_merchant 5.5 paket installiert.


    Danach habe ich die angesagten Nachinstallationen erfolgreich durch geführt. Alle 3 Installationen laufen auch soweit.



    Es geht darum das der Bestand nicht angezeigt wird, es steht nur da "In Stock".

    In anderen Templates (protos, beez) wird zumindest diese Ampel angezeigt, in Merchant gar nichts, ausser dem Text.

    Ich habe gegoogled, gelesen, überschrieben ... nix führt zum Erfolg.

    Der eine sagt ich solle die SQL Optimierung ausschalten, der andere sagt irgendwo steht das nur der Text angezeigt wird und nicht mehr. Aber er sagt nicht wo das steht und was ich als syntax einfügen müsste. (Ich kann kein html oder css, sorry)


    Meine Frage, weiß noch jemand irgend eine Möglichkeit? Es wird doch nicht normal sein.

    Ich komme nicht mehr weiter.


    Danke

    Joerg.

    wenn Du meinst, dass Du Version 10373 über 10373 gebügelt hast, dann wurde evtl. vorher der Installationsvorgang abgebrochen und nicht alle Dateien überspielt.

    Hi Stefan,

    hab ja gesagt das ich das nicht hinnehme.

    Also nochnmal das quickinstall durchgeführt. Keine Updates gemacht, nur das Sprachpacket installiert. Und, wie erwartet, es funzt, jetzt aber wirklich so wie ich will.

    Fazit.: wenn quickinstall keine updates, weil schienbar das quickinstall auf dem Stand ist das es mit der joomla version passt.

    Normalmache ich immer alle updates, aber hier bin ich in Zukunft vorsichtig.

    Auf alle Fälle läuft es jetzt so wie ich will, bis auf Kleinigkeiten, aber das wird mir auch noch gelingen.


    Danke für die Hilfe ... wenn auch nur moralisch

    Joerg